Project

General

Profile

Bug #5310

Wizard error page not correctly formatted

Added by Lorenzo Milesi almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Low
Target version:
Start date:
10/16/2015
Due date:
% Done:

100%

Estimated time:

Description

I entered a wrong hostname in the configuration wizard and the attached error message appears.

The error is not bootstrap formatted. Also there's a Close button taking to nowhere.

Other than that, pressing back causes the browser to ask confirmation to re-POST page.

screenshot-192.168.1.1 2015-10-16 07-57-35.png (44.8 KB) screenshot-192.168.1.1 2015-10-16 07-57-35.png screenshot Lorenzo Milesi, 10/16/2015 01:10 AM
screenshot-192.168.90.1.png (81.3 KB) screenshot-192.168.90.1.png screenshot Lorenzo Milesi, 10/17/2015 05:18 AM

Associated revisions

History

#1 Updated by Steve Beaver almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Steve Beaver

#2 Updated by Steve Beaver almost 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Lorenzo Milesi

Required page header and footer added to the error messages in setup_wizard.xml

"Back" button behavior is under review.

Thanks for finding this !

#3 Updated by Steve Beaver almost 4 years ago

  • % Done changed from 0 to 100

#4 Updated by Steve Beaver almost 4 years ago

wizard.php updated to generate correct jquery action handlers
dedicated wizard and include file updated to correct double "Next" buttons and other display issues.

Still need to update the multi wizard

#5 Updated by Steve Beaver almost 4 years ago

traffic_shaper_wizard_multi_all* updated and tested for correct operation/appearance

#6 Updated by Lorenzo Milesi almost 4 years ago

Error page seems now ok, but doing the same (that is entering a dot in the hostname field) results in a nonsense javascript alert.

I started the wizard from the already configured pfSense I used when I opened the issue (after updating, of course).

#7 Updated by Steve Beaver almost 4 years ago

Thanks. The Javascript alert was caused by an error I made in escaping the validation strings. Now corrected.

#8 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF