Project

General

Profile

Bug #5426

Widgets config lost after upgrade

Added by Renato Botelho almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Dashboard
Target version:
Start date:
11/12/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

After upgrade from 2.2 to 2.3, all widgets show up in closed state in dashboard. After change config and save I could compare both config.xml blocks and found 2 main differences:

1. On 2.2, all widgets name has a suffix -container, that is gone now on 2.3
2. On 2.2, all widgets stay in <widgets><sequence>, but hidden ones has the flag :none, on 2.3, only the ones that have flags :open or :close keep in the area

We need a config upgrade code to remove all items with :none, or, teach dashboard to ignore them.

History

#1 Updated by Jim Pingle almost 4 years ago

Interesting, on mine my widgets were all there post-upgrade, but some I had not added were also present and collapsed.

#2 Updated by Steve Beaver almost 4 years ago

It looks like there was an attempt to accommodate that, but it must not be working as intend.

foreach ($widgets as $widgetname => $widgetconfig)
{
    if ($widgetconfig['display'] == 'none')
        continue;

    if (!file_exists('/usr/local/www/widgets/widgets/'. $widgetname.'.widget.php')) {
        continue;
    }

I'll copy over some older config.xml and see what is going on.

#3 Updated by Renato Botelho almost 4 years ago

Jim P wrote:

Interesting, on mine my widgets were all there post-upgrade, but some I had not added were also present and collapsed.

Exactly, this is the symptom. All widgets with :none were present on 2.2 config but hidden from dashboard. On 2.3 it shows all widgets with :none as collapsed

#4 Updated by Renato Botelho almost 4 years ago

Steve Beaver wrote:

It looks like there was an attempt to accommodate that, but it must not be working as intend.

[...]

I'll copy over some older config.xml and see what is going on.

Here is a 2.2 config example:

        <widgets>
                <sequence>system_information-container:col1:show,captive_portal_status-container:col1:close,carp_status-container:col1:close,cpu_graphs-container:col1:close,gateways-container:col1:close,gmirror_status-container:col1:close,installed_packages-container:col1:close,interface_statistics-container:col1:close,interfaces-container:col2:show,ipsec-container:col2:close,load_balancer_status-container:col2:close,log-container:col2:close,picture-container:col2:close,rss-container:col2:close,services_status-container:col2:close,traffic_graphs-container:col2:close,dyn_dns_status-container:col2:none,ntp_status-container:col2:none,openvpn-container:col2:none,smart_status-container:col2:none,thermal_sensors-container:col2:none,wake_on_lan-container:col2:none</sequence>
        </widgets>

#5 Updated by Renato Botelho almost 4 years ago

  • Status changed from New to Duplicate

Duplicate of #5432

Also available in: Atom PDF