Project

General

Profile

Bug #5443

Package LADVD display wrong text in gui.

Added by Jeremy Porter over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Jeremy Porter
Target version:
Start date:
11/13/2015
Due date:
% Done:

100%

Estimated time:

Description

The second bit of text is correct, but the description appears wrong. This might impact multiple packages:
Enable LLDP
Show log entries in reverse order (newest entries on top)
Enable LLDP (Link Layer Discovery Protocol).

The "Show log entries" text is display for the next three items as well.

LADVD.jpg (72.5 KB) LADVD.jpg Steve Beaver, 11/13/2015 09:31 PM
Selection_024.png (38.6 KB) Selection_024.png Chris Buechler, 11/14/2015 12:32 AM

Associated revisions

History

#1 Updated by Jim Thompson over 3 years ago

screenshots would be nice.

#2 Updated by Steve Beaver over 3 years ago

After installing the LADVD package, its webpage (Services->LADVD) displays incorrect text.

The page is generated by pkg_edit.php using ladvd.xml, so the issue could be in either of those.

#3 Updated by Steve Beaver over 3 years ago

#4 Updated by Kill Bill over 3 years ago

I have hard time understanding what "incorrect text" is shown where, even with the screenshot.

#5 Updated by Chris Buechler over 3 years ago

The screenshot Steve posted is from 2.2.x, where it's correct. Attached is from 2.3, where it's getting "Show log entries ..." from somewhere other than the package's XML.

#6 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Confirmed

#7 Updated by Chris Buechler over 3 years ago

a slew of instances of that "Show log entries" message in pkg_edit.php that looks like a wrong copy/paste.

#8 Updated by Kill Bill over 3 years ago

Chris Buechler wrote:

a slew of instances of that "Show log entries" message in pkg_edit.php that looks like a wrong copy/paste.

Ah yeah, this thing is screwed from the very beginning (initial "conversion" - https://github.com/pfsense/pfsense/blob/23f6cdd72757350d8c25cf9536c7d7dafc6fca16/src/usr/local/www/pkg_edit.php)

Sigh.

#9 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jeremy Porter

Error rectified in checkbox generation func.

#10 Updated by Steve Beaver over 3 years ago

  • % Done changed from 0 to 100

#11 Updated by Jeremy Porter over 3 years ago

  • Status changed from Feedback to Closed

Looks good. Fixed.

#12 Updated by Chris Buechler over 3 years ago

  • Status changed from Closed to Resolved

fixed, thanks

Also available in: Atom PDF