Project

General

Profile

Todo #5478

Page title text duplication

Added by Chris Buechler almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
11/18/2015
Due date:
% Done:

100%

Estimated time:

Description

Pages have their title displayed twice right next to each other, which is redundant and chews up screen space unnecessarily. Like the attached, with "Advanced: System Tunables", and "System / Advanced: System Tunables" underneath.

I think it'd be fine to remove the first, large instance and leave the second as-is.

Selection_025.png (27.1 KB) Selection_025.png Chris Buechler, 11/18/2015 03:16 AM

Associated revisions

Revision 1908003a (diff)
Added by Jared Dillard almost 4 years ago

Fixed #5478 clean up title text

History

#1 Updated by Steve Beaver almost 4 years ago

The first line is the page title. (What this page does)
The second line contains the breadcrumbs (how we got here)

A better solution might be to style the breadcrumbs using a smaller font and a distinctive color to make their meaning more obvious, while taking up less space?

#2 Updated by Chris Buechler almost 4 years ago

Is there any situation in which the page title isn't contained in the breadcrumbs?

#3 Updated by Jared Dillard almost 4 years ago

check out the dark theme, I hid the first line and made the breadcrumbs a larger font. This is the reason I want the breadcrumbs on the dashboard, because the styling breaks there.

Note: As long as the HTML is consistent, this can be done with CSS and left up to the "theme designer" incase someone else wants to make a theme that is different.

#4 Updated by Steve Beaver almost 4 years ago

  • Tracker changed from Bug to Todo
  • Assignee set to Jared Dillard

Breadcrumbs are now generated on index.php allowing their display to be controlled by CSS.

Re-assigning to JDillard.

#5 Updated by Jared Dillard almost 4 years ago

  • Assignee changed from Jared Dillard to Chris Buechler

I can't change the status to Feedback, but I committed CSS changes that removes the first line and make the 2nd line bigger.

#6 Updated by Anonymous almost 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#7 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

looks good

Also available in: Atom PDF