Project

General

Profile

Bug #5552

Top menu sometimes blinks/reloads when selecting items on 2.3

Added by Eduard Rozenberg over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
11/28/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

I can't pin down a pattern - the same menu item will sometimes cause a menubar blink/reload when selected, and sometimes not.
Would be nice to never see this menubar reloading - would make the interface feel more solid.

Running alpha 2.3 latest iso x64 on VMWare Fusion Mac 8.0.2.

Video attached.

Associated revisions

Revision 840390d1 (diff)
Added by Jared Dillard over 3 years ago

Fixed #5552 backed out hover dropdown changes for now

History

#1 Updated by Jim Pingle over 3 years ago

  • Category set to Web Interface
  • Status changed from New to Confirmed
  • Assignee set to Jared Dillard
  • Target version set to 2.3

Seems to happen if you click on the menu name rather than letting pointer hovering open the menu. At least in Firefox and Chromium on Linux, Windows, and Mac. Definitely a new behavior since changing to the OAGF-style menu that follows you around, since on the menu stuck at the top you had to click to open.

Both Jared and Steve have been working on the menu, assigning to Jared since it looks like he was working on it last.

#2 Updated by Eduard Rozenberg over 3 years ago

The blinking/reload I experienced and referred to in the attachment "pfSense 2.3 Toolbar Sometimes Blinks Reloads.mp4" was of the main menubar itself (the one containing the main menus such as "... VPN Status Diagnostics ...", not the pulldown submenus.

Could be the two blinking problems are related and have the same cause, though.

#3 Updated by Jared Dillard over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Jared Dillard to Jim Pingle

I backed out a change I made for dropdown to work on hover. They are click only for now until a more robust solution is brought forward.

#4 Updated by Anonymous over 3 years ago

  • % Done changed from 0 to 100

#5 Updated by Jim Pingle over 3 years ago

  • Assignee deleted (Jim Pingle)

It looks good here now (had to clear the cache though) -- menu opens on click but does not misbehave. Leaving open for feedback from the original reporter.

#6 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

fixed

#7 Updated by Eduard Rozenberg over 3 years ago

The blinking shown in this bug's attachment "pfSense 2.3 Toolbar Sometimes Blinks Reloads.mp4" is still there as of 2.3-ALPHA (amd64) built on Fri Dec 04 07:17:27 CST 2015.

This menubar blinking/reload is ONLY seen on Safari so far (OS X 10.11, Safari Version 9.0.1 (11601.2.7.2)).

The menubar/blinking/reload is NOT seen on Firefox Mac 42.0 or Chrome Mac Version 47.0.2526.73 (64-bit). The UI menus are working solid on these browsers.

But - the handful of Safari users out here would love a perfected pfSense 2.3, as well :). Thanks!

#8 Updated by Chris Buechler over 3 years ago

What blinking, just the page reload I guess? Not seeing anything bad in the mp4. The real problem here was what jimp noted, which has been fixed.

#9 Updated by Eduard Rozenberg over 3 years ago

Right - just the page blinking, only noticeable on Safari as mentioned. For sure only a minor annoyance.

Also available in: Atom PDF