Project

General

Profile

Bug #5603

two issues with dynamic dns regsitration from dhcp

Added by Jeremy Porter over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
DHCP Server
Target version:
Start date:
12/05/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Line 995 in /usr/local/www/services_dhcp.php Input Type is being set to "number" should be "text".
However with that fixed, /var/dhcpd/etc/dhpcd.conf still does not contain correct ddyn entries.
zone skinnydog.org. {
primary 192.207.126.6;
}
This should be like:
zone skinnydog.org. {
primary 192.207.126.6;
key "skinnydog";
}
The key name is set, and valid in the config.xml.
Looks like it might be in the block around line 1138 in /etc/services.inc.
Although its not creating the key entry in /var/dhcpd/etc/dhcpd.conf either, so maybe not.

Associated revisions

Revision 7c1747a3 (diff)
Added by Chris Buechler over 3 years ago

Fix DDNS dhcpd(v6).conf config generation issues. Ticket #5603

History

#1 Updated by Jim Thompson over 3 years ago

  • Assignee set to Renato Botelho

seems straight-forward to fix

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Confirmed
  • Affected Version set to 2.3

#3 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Renato Botelho to Jeremy Porter

Jeremy fixed part of this here.
https://github.com/pfsense/pfsense/commit/e8da0bcd6b62cc3691775337e96440ae41993780

The remainder all looks to work fine. I get a proper dhcpd.conf now, though services.inc hasn't changed since then. Either fixing the GUI part fixed everything, or there's something more to it that I'm not hitting.

Jeremy, you still seeing any issues here?

#4 Updated by Jeremy Porter over 3 years ago

Ya, even after disabling ddns updates and re-enabling, I'm still not seeing the "key" statements for the zone, or the actual update key being included.

Chris can you check your ddns and make sure the /var/dhcp/etc/dhcpd.conf has the key statements and the key defined?

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Jeremy Porter to Chris Buechler
  • Affected Version changed from 2.3 to All

See the issue after working on Jeremy's system. It's actually never worked correctly if the last enabled DHCP server instance didn't have the keys defined on it.

#6 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback

this looks to be correct in all cases now.

#7 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

Jeremy's situation is confirmed working now. Every other circumstance still looks good too.

Also available in: Atom PDF