Project

General

Profile

Bug #5615

hover/popover-popup goes away when you move mousepointer towards the popup (=away from original target button/icon/a)

Added by jeroen van breedam over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Very Low
Assignee:
Category:
Web Interface
Target version:
Start date:
12/08/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

example:
firewall_rules.php
  • hover over an alias, that is used on a rule.
  • popup pops-->shows contents of alias
  • try to hover over popup or scroll down to see more of the content below or copy some of the date <--- popup closes when mousepointer leaves original target = not good.

workaround by someone: http://jsfiddle.net/wojtekkruszewski/zf3m7/22/

i've implemented this on the pfblocker widget i've been testing. this seems to work.

Maybe this improved code could be added to base?

Associated revisions

Revision 76bd03bb (diff)
Added by Jared Dillard over 3 years ago

ticket #5615 fix popover hover

History

#1 Updated by Chris Buechler over 3 years ago

  • Description updated (diff)
  • Category set to Web Interface
  • Status changed from New to Confirmed
  • Assignee set to Jared Dillard
  • Target version set to 2.3
  • Affected Version set to 2.3

#2 Updated by Chris Buechler over 3 years ago

  • Priority changed from Normal to Very Low

the type of behavior linked in OP would be nicer, but it'd be no big deal to leave things as-is.

#3 Updated by Jared Dillard over 3 years ago

  • Status changed from Confirmed to Closed

Thanks for the workaround it is added to base. Unfortunately on the firewall rules page you can't easily copy the data because it wants to drag the row.

#4 Updated by Jared Dillard over 3 years ago

  • Status changed from Closed to Resolved

Also available in: Atom PDF