Project

General

Profile

Bug #5617

Minor GUI issues (formatting/text)

Added by Landon Timothy over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
12/08/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Great work so far on the 2.3 interface.
Thought I should point out a few minor issues.
Just updated to the most recent snapshot - Tue Dec 08 10:12:30 CST 2015

1- Status->System Logs->Settings
The first 2 settings under Log Firewall Default Blocks are similar, but the description is confusing on the first one.

2- System->Advanced
Under Serial Communications "null modem" is bolded, but there are no spaces around it.

3- Status->OpenVPN
Peer to Peer server statistics is missing a column header for connection status so the column headers don't match the statistics.

Thanks.

1.PNG (30.7 KB) 1.PNG System Logs Landon Timothy, 12/08/2015 07:56 PM
2.PNG (23.8 KB) 2.PNG null modem Landon Timothy, 12/08/2015 07:56 PM
3.PNG (36.2 KB) 3.PNG OpenVPN server statistics Landon Timothy, 12/08/2015 07:56 PM
OpenVPN status1.png (38.1 KB) OpenVPN status1.png Landon Timothy, 12/15/2015 11:16 PM
OpenVPN status2.png (32.5 KB) OpenVPN status2.png Landon Timothy, 12/15/2015 11:16 PM

Associated revisions

Revision e9701cfe (diff)
Added by Steve Beaver over 3 years ago

Fixed #5617
Table columns corrected

Revision 56fafd85 (diff)
Added by Steve Beaver over 3 years ago

Fixed #5617
Added ID and style to routing table

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Steve Beaver

#2 Updated by Chris Buechler over 3 years ago

  • Category set to Web Interface
  • Target version set to 2.3
  • Affected Version set to 2.3

#3 Updated by Steve Beaver over 3 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Landon Timothy

Minor fixes applied. Thanks!

#4 Updated by Steve Beaver over 3 years ago

  • % Done changed from 0 to 100

#5 Updated by Landon Timothy over 3 years ago

Finally had a chance to update snapshots today.
The first two look better, but OpenVPN status still looks the same.

#6 Updated by Steve Beaver over 3 years ago

Yes. I fixed a column count issue in the table body, but the footer section is horrid. I need to find a screenshot of the way it looks with 2.2.x to allow me to better format it.

#7 Updated by Steve Beaver over 3 years ago

Got some help with the desired appearance which allowed me to revise the table columns/headers. Would you remind retesting please?

#9 Updated by Landon Timothy over 3 years ago

Peer to Peer status looks better now.
I hadn't had remote access connected previously, but it needs some help too.
I've added a pic. but it shows a panel for the routing table (that looks like the same info as the status panel)
Clicking on the show routing table button just makes the button disappear.

One last thing.. I think it would look better to have the service status and stop/restart buttons look consistent for both remote access and peer to peer.
Thanks.

#10 Updated by Steve Beaver over 3 years ago

I don't have a test setup to duplicate the routing table issue, but I think I see what the problem is and have made some changes to address it. Would you mind trying it out please?

The routing table panel shown in you screenshot should now appear only when the button is clicked.

#12 Updated by Steve Beaver over 3 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF