Project

General

Profile

Bug #571

Destination on rdr incorrect on interface addresses

Added by Chris Buechler about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Rules/NAT
Target version:
Start date:
05/06/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When you select any interface address in port forward entries now, it puts them into the config as something like:

                        <destination>
                                <network>opt1ip</network>
                                <port>80</port>
                        </destination>

Which results in an incorrect mask on the destination, it uses the interface's mask. Where you end up with:

rdr on em2 proto tcp from any to 6.4.1.13/29 port 80  -> 10.10.2.6

where it should be /32 not /29

Associated revisions

Revision 0167a9bf (diff)
Added by Erik Fonnesbeck about 9 years ago

Fix the regular expression used in filter_generate_address for OPT subnet so that it only matches the case intended. Ticket #571

History

#1 Updated by Erik Fonnesbeck about 9 years ago

I've tried it out and haven't been able to reproduce this. I get just the IP address.

#2 Updated by Erik Fonnesbeck about 9 years ago

Actually, it seems to be an issue only when using opt interfaces.

#3 Updated by Erik Fonnesbeck about 9 years ago

Confirmed that the issue is not exclusive to port forwards. The same happens with firewall rules.

#4 Updated by Erik Fonnesbeck about 9 years ago

  • Status changed from New to Feedback

Should be fixed now.

#5 Updated by Erik Fonnesbeck about 9 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF