Project

General

Profile

Actions

Bug #5710

closed

firewall_nat_edit.php target custom port field not grayed out where should be

Added by Chris Buechler almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
12/28/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3
Affected Architecture:

Description

On firewall_nat_edit.php, the custom port box for "Redirect target port" doesn't get grayed out when an option is chosen from the drop down. It should behave the same as "Source port range" and "Destination port range" on that page - if something is picked from the drop down (say, HTTP), then the Custom box gets grayed out.

This snippet looks like it's trying to do that.

                if (($('#localbeginport').find(":selected").index() == 0) && portsenabled) {
                        disableInput('localbeginport_cust', false);
                } else {
                        $('#localbeginport_cust').val('');
                        disableInput('localbeginport_cust', true);
                }

but it doesn't actually disable/enable the field.

Actions #1

Updated by Steve Beaver almost 6 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

2.2.x seems to behave the same way. The reason is that although the Javascript does disable this control, it is immediately re-enabled by code based on the protocol.

I have commented out that piece for now. I'm pretty sure there should be no unwanted side effects and that this makes the page operate correctly.

Actions #2

Updated by Steve Beaver almost 6 years ago

  • % Done changed from 0 to 100
Actions #3

Updated by Chris Buechler almost 6 years ago

  • Status changed from Feedback to Resolved

works

Actions

Also available in: Atom PDF