Project

General

Profile

Bug #5724

Phase1 checkboxes on vpn_ipsec.php cannot be checked by clicking on them & missing row_toggle.js javascript

Added by Pi Ba over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
IPsec
Target version:
Start date:
01/02/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:
amd64

Description

on Chrome Phase1 checkboxes on vpn_ipsec.php cannot be checked by clicking on them & missing row_toggle.js javascript

Error in console for loading: vpn_ipsec.php:203 GET /javascript/row_toggle.js
p.s. The whole javascript folder gets deleted on every (daily) automatic snapshot upgrade.. is that supposed to happen?

Associated revisions

Revision c0d9e7cc (diff)
Added by Chris Buechler over 3 years ago

Remove reference to obsoleted row_toggle.js. Noted in Ticket #5724

History

#1 Updated by Steve Beaver over 3 years ago

Yes, it is supposed to delete the old javascript folder. Nothing in there should be required by 2.3.x.
fr_toggle() and friends are now in jQuery/pfSenseHelpers.js
I'll look at the checkbox toggle matter shortly.

#2 Updated by Pi Ba over 3 years ago

The missing /javascript/ folder i noticed mostly because of haproxy package that also placed a javascript file there, that got deleted on regular basis.. I suppose ill move it to a different folder.. www/haproxy/ or something like that.

#3 Updated by Steve Beaver over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to Pi Ba
  • Target version set to 2.3

fr_toggle() had been added to both the row and the cell causing it to toggle twice, and so appear not to toggle at all.

#4 Updated by Steve Beaver over 3 years ago

  • % Done changed from 0 to 100

#5 Updated by Pi Ba over 3 years ago

Confirmed fixed, thanks.

#6 Updated by Steve Beaver over 3 years ago

  • Status changed from Feedback to Resolved

#7 Updated by Pedro Caetano over 3 years ago

Everything seems to work ok, but i'm still observing similar messages in system logs:
It happens every time /vpn_ipsec.php is accessed.
It is also visible while applying changes to phase1 / phase2 settings.

I'm running 2.3.b.20160109.1400

My browser is mozilla firefox 43.0.3 on fc23 64bit.

Best regards,
Pedro Caetano

#8 Updated by Pedro Caetano over 3 years ago

missing logs are here:
nginx: 2016/01/10 19:22:03 [error] 84391#0: *91 open() "/usr/local/www/javascript/row_toggle.js" failed (2: No such file or directory), client: 172.24.32.5, server: , request: "GET /javascript/row_toggle.js HTTP/1.1", host: "10.192.22.131", referrer: "https://10.192.22.131/vpn_ipsec.php"

#9 Updated by Chris Buechler over 3 years ago

Thanks Pedro, I removed the reference to that obsoleted file.

Also available in: Atom PDF