Project

General

Profile

Bug #5739

powerd fails on some hardware with "no cpufreq(4) support -- aborting"

Added by David McCoy about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Very Low
Assignee:
-
Category:
Operating System
Target version:
Start date:
01/06/2016
Due date:
% Done:

0%

Affected version:
2.3
Affected Architecture:
All

Description

PowerD does not seem to run in 2.3 beta. No status on the dashboard, and there is an error during boot or when changing settings.

Jan 6 21:15:07    php-cgi        rc.bootup: The command '/usr/sbin/powerd -b hadp -a hadp -n hadp' returned exit code '69', the output was 'powerd: no cpufreq(4) support -- aborting: No such file or directory'

Getting the same message on 20160106 when running powerd on x64 nanobsd (APU) and x86 nanobsd (alix).

History

#1 Updated by Chris Buechler about 1 year ago

  • Subject changed from powerd not running to powerd fails on some hardware with "no cpufreq(4) support -- aborting"
  • Description updated (diff)
  • Status changed from New to Confirmed
  • Target version set to 2.3

This is apparently because of a defaults change in FreeBSD 10.2 and newer. Change the following two lines in /boot/device.hints and reboot and it works.

hint.acpi_throttle.0.disabled="0" 
hint.p4tcc.0.disabled="0" 

That is not always necessary for powerd to function. It works fine on RCC-VE in 2.3 as-is. APU and ALIX at least require changing that.

#2 Updated by Chris Buechler about 1 year ago

  • Priority changed from Normal to Very Low

I think we may just have to instruct users with hardware requiring the acpi_throttle and p4tcc to change those accordingly. None of the hardware we sell (and test thoroughly) requires that. Trying to detect systems like that and set it accordingly is more trouble than it's worth. Open to suggestions.

#3 Updated by Jim Thompson about 1 year ago

  • Status changed from Confirmed to Resolved

That is the suggestion.

The hardware we support gets this kind of test coverage.

DIY people are left to implement work-arounds when their BIOS is flakey.

Also available in: Atom PDF