Project

General

Profile

Bug #5748

stf interface IPv6 IP never leaves tentative state

Added by Will Wainwright over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
01/08/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Hi guys,

I'm running 2.3 built on Fri Jan 08 15:32:00.

I use Charter's 6RD service which works great but I have to give the gateway monitor an address to ping. With 2.3 my gateway monitor doesn't come up when I specify the same address I use in 2.2.6.

I can see dpinger is running in "ps -aux" with an ipv4 address that makes sense & I can see the ipv4 gateway in /var/log/gateways.log but there isn't any ipv6 stuff in there at all.

I suspect it's related to issue #5711. If you tell me how to run "setup_gateways_monitor()" to manually see if I can get the ipv6 monitor working I'd be happy to try.

-Will

History

#1 Updated by Chris Buechler over 3 years ago

  • Category set to Gateway monitoring
  • Assignee set to Chris Buechler
  • Target version set to 2.3
  • Affected Architecture deleted (amd64)

on a version that new it's not related to #5711. this is already something I was planning on going back to check for 6rd, to me for review.

#2 Updated by Chris Buechler over 3 years ago

Will: what does your ifconfig output show for the wan_stf interface?

#3 Updated by Will Wainwright over 3 years ago

Hi Chris,

This is what I get:

[2.3-BETA][]/root: ifconfig wan_stf
wan_stf: flags=4001<UP,LINK2> metric 0 mtu 1280
inet6 2602:100:470e:4f67:: prefixlen 32 tentative
nd6 options=1<PERFORMNUD>
v4net 71.14.79.103/32 -> tv4br 68.114.165.1

-Will

#4 Updated by Chris Buechler over 3 years ago

Thanks, I thought maybe my test setup was just being weird in never leaving "tentative" state, guessing yours is working, but the v6 IP on the stf interface never leaves tentative? That's probably the issue, which is actually in 6rd not gateway monitoring.

#5 Updated by Chris Buechler over 3 years ago

  • Subject changed from IPv6 gateway monitor status to stf interface IPv6 IP never leaves tentative state
  • Category changed from Gateway monitoring to Operating System
  • Status changed from New to Confirmed

#6 Updated by Chris Buechler over 3 years ago

This is broken in 10-STABLE, now has open bug here:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=206231

#7 Updated by Chris Buechler over 3 years ago

the change in the patch on PR 206231 seems reasonable, not sure why it's still sitting there. I added that to our builds to test.

#8 Updated by Will Wainwright over 3 years ago

Hi Chris,

I just updated to the Sat Jan 23 11:51 build & my ipv6 gateway monitor is running now.

I'll let you know if anything changes.

-Will

#9 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback

Thanks for the confirmation, Will.

This fixes other circumstances I was seeing as well. Following up on that FreeBSD PR to see if that can be committed.

This is fixed, but leaving to feedback because we want it to be fixed in FreeBSD and to revert the change from our tree.

#10 Updated by Renato Botelho over 3 years ago

  • Status changed from Feedback to Resolved

This issue is fixed in pfSense. I'll keep track of FreeBSD changes and revert it when it's time

Also available in: Atom PDF