Project

General

Profile

Bug #5776

pfsense logon from iOS devices (Defaults to uppercase for first letter in username)

Added by Marco Novielli over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
01/16/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

It would be nice for the login form to default to lowercase for the username. Currently, if you are logging in from an iOS device, the first letter in the username defaults to uppercase from the device. It's a bit of a pain to have to remember to turn off the shift so that "admin" doesn't become "Admin". I have used web forms in other apps such as Guacamole, and they seem to default to lowercase, which I would imagine would be the preference for most.

BTW, love what pfSense 2.3 is becoming. Very slick.

Associated revisions

Revision bf210329 (diff)
Added by Chris Buechler over 3 years ago

autocapitalize off is deprecated, use none instead. Ticket #5776

History

#1 Updated by jeroen van breedam over 3 years ago

this works on android, don't have iOS to test this on.

https://github.com/pfsense/pfsense/pull/2452

#2 Updated by Steve Beaver over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to Marco Novielli

#3 Updated by Marco Novielli over 3 years ago

I found references stating that autocapitalize="off" is now deprecated and should be changed to autocapitalize="none"

http://stackoverflow.com/questions/5171764/how-do-you-turn-off-auto-capitalisation-in-html-form-fields-in-ios

https://developer.apple.com/library/safari/documentation/AppleApplications/Reference/SafariHTMLRef/Articles/Attributes.html#//apple_ref/doc/uid/TP40008058-autocapitalize

I will test once it is merged, and will let you know if this is resolved on iOS.

#4 Updated by Marco Novielli over 3 years ago

Just pulled the update from master and I have confirmed that it is working as expected on iOS Safari. The username field now defaults to lowercase for the first letter. I will leave it with you on whether it should be changed to autocapitalize="none" instead of autocapitalize="off", as referenced. Thx.

#5 Updated by Chris Buechler over 3 years ago

  • Category set to Web Interface
  • Status changed from Feedback to Resolved

I changed it to use "none" instead since off is deprecated. Fixed

Also available in: Atom PDF