Project

General

Profile

Bug #5844

Gateway groups VIPs not selected on edit, VIP list wrong

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
02/05/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

On system_gateway_groups_edit.php, picking a virtual IP and saving does set it in the config, but upon editing the group, the VIP is not selected.

The VIP list shown is wrong in that it lets you pick something on the wrong interface. That page in previous versions showed only the VIPs that are associated with the specific WAN on each row.

Associated revisions

Revision 70648bdb (diff)
Added by Chris Buechler over 3 years ago

Select appropriate VIP where one is configured. Ticket #5844

Revision c9bcaae1 (diff)
Added by Chris Buechler over 3 years ago

Only show VIPs associated with the correct interface. Ticket #5844

Revision d18c26fb (diff)
Added by Chris Buechler over 3 years ago

Just show the IP to the user, the VIP's uniqid is meaningless noise to the user. Ticket #5844

Revision f54728df (diff)
Added by Chris Buechler over 3 years ago

$interface isn't used here. Wasn't before either, otherwise it would have broken the get_configured_carp_interface_list. Ticket #5844

Revision 2a5960b0 (diff)
Added by Luiz Souza over 3 years ago

Review of CARP uniqid changes.

It turns out that current CARP implementation is not much different from an IP alias.

This commit converts the IP alias to also use the CARP uniqid scheme, this simplify the code in all other places because now we have only two different cases to deal with:

- A friendly interface name (lan, wan, opt1, etc.);
- A Virtual IP - VIP alias (_vip{$uniqid}) - CARP or IP Alias.

The parent of a CARP is always a friendly interface. The parent of an IP alias can be a friendly interface or a CARP (this is the only case of recursion of a VIP).

This commit removes a few cases where CARP were still considered a interface (the old CARP implementation), fixes all the wrong cases of strpos() being used to detect a VIP address (wont work as it returns '0' which fails when tested as 'TRUE'), review the usage of CARP and IP alias as services bind addresses, fixes general issues of adding and editing VIP addresses.

The following subsystems were affected by this changes:

- IPSEC;
- OpenVPN;
- dnsmasq;
- NTP;
- gateways and gateway groups;
- IPv6 RA;
- GRE interfaces;
- CARP status;
- Referrer authentication.

Fixes (and/or revisit) the following tickets:

- Ticket #3257
- Ticket #3716
- Ticket #4450
- Ticket #4858
- Ticket #5441
- Ticket #5442
- Ticket #5500
- Ticket #5783
- Ticket #5844

Revision 95b07096 (diff)
Added by Chris Buechler over 3 years ago

Only show VIPs on the correct interface. Ticket #5844

History

#1 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee set to Chris Buechler

looks to be all working correctly now, leaving for additional testing

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

fixed

#3 Updated by Luiz Souza over 3 years ago

  • % Done changed from 0 to 100

Gateway groups have been tested and reviewed together with IP Aliases and CARP.

#4 Updated by Chris Buechler over 3 years ago

  • Status changed from Resolved to Confirmed

the "VIP list wrong" part of this regressed after 2a5960b0

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback

fixed again

#6 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF