Project

General

Profile

Bug #5910

apply button on adding ipv6 static mapping deletes dhcpv6 settings

Added by Michael Kellogg over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DHCP6
Target version:
Start date:
02/19/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:
All

Description

the apply button upon adding or editing ipv6 static mappings causes dhcpv6 to loose settings and deactivates dhcpv6
jimp suggested referencing bug: https://redmine.pfsense.org/issues/5488

Associated revisions

Revision 8f36f87a (diff)
Added by Jim Pingle over 3 years ago

Move the DHCPv6 apply action into a function. Capture the apply and save actions separately and only perform the required task. Fixes #5910

History

#1 Updated by Steve Beaver over 3 years ago

  • Assignee set to Jim Pingle

#2 Updated by Jim Pingle over 3 years ago

  • Category set to DHCP6
  • Status changed from New to Confirmed
  • Target version set to 2.3
  • Affected Architecture set to All

Yep, definitely an issue.

Edit a v6 static mapping, click save, looks OK until you click Apply and then the settings are gone.

#3 Updated by Jim Pingle over 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#4 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

once I got a scenario that presented an apply changes button, that was easily replicable. Fixed now

Also available in: Atom PDF