Project

General

Profile

Bug #6097

Crashreporter, should show php warnings, not only their stacktrace..

Added by Pi Ba about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
04/09/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Crashreporter, should show php warnings, not only their stacktrace.

A php error like reported here https://forum.pfsense.org/index.php?topic=109447.msg609363#msg609363 where only a stacktrace is shown but the actual error/warning is hidden makes it more difficult to debug.

My preference would be to just show the whole contents of the /tmp/PHP_errors.log file, not filtering out lines that contain the word 'warning'..

History

#1 Updated by Chris Buechler about 3 years ago

  • Status changed from New to Confirmed
  • Target version changed from 2.3 to 2.3.1
  • Affected Version changed from 2.3 to All

#2 Updated by Chris Buechler about 3 years ago

  • Target version deleted (2.3.1)

It needs to completely ignore warnings in release versions (#6178) as it's a massive amount of useless noise.

For development versions, this would be good.

#3 Updated by Chris Buechler about 3 years ago

  • Status changed from Confirmed to Resolved
  • Target version set to 2.3.1

Issue fixed in 918f0a9469aa05a9300a25c2ca60e2be83411226.

That won't end up doing anything differently in 2.3.1 since PHP warnings aren't being logged there, but good to go for future development versions.

Also available in: Atom PDF