Project

General

Profile

Bug #6122

Hostname Field for NameCheap Dynamic DNS Rejects "@"

Added by Trel S about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Dynamic DNS
Target version:
Start date:
04/12/2016
Due date:
% Done:

100%

Affected Version:
2.3
Affected Architecture:

Description

The hostname field for NameCheap in dynamic DNS is rejecting the "@" character.

Error Below:
The following input errors were detected:

The hostname contains invalid characters.

Expected Behavior: Allow the "@" character in the hostname field.

namecheap-host-fix-6122.patch Magnifier (693 Bytes) Jim Pingle, 04/13/2016 09:32 AM

Associated revisions

Revision 7cb8fabc
Added by Jim Pingle about 2 years ago

Fix Namecheap DynDNS host parsing for @, fixes #6122

Revision cc0b9f91
Added by Jim Pingle about 2 years ago

Fix Namecheap DynDNS host parsing for @, fixes #6122

History

#1 Updated by Trel S about 2 years ago

Affected Version: 2.3 release.

#2 Updated by Jim Pingle about 2 years ago

  • File namecheap-host-fix-6122.patchMagnifier added
  • Category set to Dynamic DNS
  • Assignee set to Jim Pingle
  • Target version set to 2.3.1
  • Affected Version set to 2.3

Attached patch should fix it, waiting on confirmation since none of my domains on Namecheap are setup in such a way that I can update using @ safely.

#3 Updated by Trel S about 2 years ago

With that patch applied, it accepted the "@" symbol for the hostname.

Additionally, I confirmed that it correctly updated the correct record at NameCheap.

#4 Updated by Jim Pingle about 2 years ago

Thanks for the confirmation, I just pushed the fix

#5 Updated by Jim Pingle about 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#6 Updated by Chris Buechler about 2 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF