Project

General

Profile

Bug #6179

Not obtaining update status on nanobsd when read-only mounted

Added by M S about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
04/16/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:
All

Description

Good morning,
I update my alid2d13 from pfsense 2.2.6 to 2.3 two days ago. Before doing so, I uninstalled all packages.
After install, I made no changes to the config and did not yet re-install any packages.
I noticed two things:
- my installation of pfsense cannot obtain update status, instead the little wheel indicating activity keeps on turning... (see att'd pic)
- my installation is lagging. it takes more >15 secs. to, say, switch from Dashboard to showing the DHCP leases, but that applies to all other menu items.
I rebooted twice, but no effect.
Is that an issue with the update or with my config ? But I made no change at all to the config.
Move to forum, if you consider this not to be bug.
Thanks for taking care
Marc

pfsense.jpg (304 KB) pfsense.jpg M S, 04/16/2016 12:21 AM
Screen Shot 2016-04-26 at 8.05.06 PM.png (238 KB) Screen Shot 2016-04-26 at 8.05.06 PM.png Ken Thieme, 04/26/2016 08:08 PM
RW-Mode.jpg (150 KB) RW-Mode.jpg Read-write mode M S, 04/29/2016 11:01 AM
CPU usage 100percent.jpg (313 KB) CPU usage 100percent.jpg CPU usage at 100% M S, 04/29/2016 11:01 AM

History

#1 Updated by Jim Thompson about 3 years ago

  • Assignee set to Renato Botelho

#2 Updated by Jim Thompson about 3 years ago

  • Target version set to 2.3.1
  • Affected Architecture set to All

moved to 2.3.1, feel free to move this to 2.3.2

#3 Updated by Chris Buechler about 3 years ago

M S: Does it just stick there at "obtaining update status"? That makes it seem like the javascript is failing browser-side, try clearing your browser cache. Whether it fails or succeeds, it'll come back with some other status.

If you browse to System>Update, what do you get?

#4 Updated by M S about 3 years ago

Chris, it just sticks there. I use Opera 36 as my standard browser and have cleared the browser's cache. Same happens if I use Windows (10)' Edge browser.
Browsing to System>Update doesn't work at all (neither Opera nor Edge). It just hangs and won't go to System/Update...
Regards
Marc

#5 Updated by Chris Buechler about 3 years ago

If you go to System>Advanced, Networking tab, and check the box to prefer IPv4 over IPv6 then reboot, does it still do that?

#6 Updated by Erhard F. about 3 years ago

I am experiencing the same issue on my alix2d13. I checked the "prefer IPv4 over IPv6"-box in advanced settings, cleared the browser cache (Chromium 50) an rebooted. Unfortunately the issue remains. If I browse to System>Update I get an "504 Gateway Time-out (nginx)" screen after some waiting.

One time I acutally got to the System>Update screen. This was during a reboot, more to the point shortly after starting the reboot process but before the alix completed rebooting. But I was not able to reproduce this.

#7 Updated by M S about 3 years ago

Chris,
yes, checking the box and preferring IPv4 over IPv6 doesn't help. I rebooted but can't see System/Update. And that little wheel keeps on turning...
Marc

#8 Updated by M S about 3 years ago

Chris, would it help to send my config file (without the personal data) ? If so, to what address ?

#9 Updated by Chris Buechler about 3 years ago

  • Assignee changed from Renato Botelho to Chris Buechler

It's not likely specific to your config, rather the environment, but yeah send me a backup. cmb at pfsense dot org

Also, go to a command prompt, option 8 at the console via SSH, and run 'pkg update'. What does that show?

#10 Updated by Ken Thieme about 3 years ago

Running Alix box and experiencing same issues. Update gear never stops in dashboard. System->Update results in 504 error. Running pkg update in shell returns nothing.

#11 Updated by Greg Carnie about 3 years ago

I'm experiencing the exact same issue. Never obtaining update status, high CPU usage, timeouts when browsing the web ui, timeouts when attempting to connect with putty. What can I do to help?

#12 Updated by jim arnold about 3 years ago

Same issue as Ken Theime with my ALIX box. Also takes a long time for the page to come up.

#13 Updated by Chris Buechler about 3 years ago

  • Subject changed from pfsense 2.3 not obtaining update status to Not obtaining update status on nanobsd when read-only mounted
  • Status changed from New to Confirmed

I believe new subject is the root cause of everyone's issue here. Where 'pkg update' just returns with no output, that's why. The update check fails for the same reason. Mount rw and everything works as expected.

#14 Updated by M S about 3 years ago

Chris,

thanks. I checked this when I got home. But: my system already was mounted r/w (see att'd picture). I have rebooted, but still no change. CPU is @ 100% (pic #2). Anyone else here who is experiencing the same issue who has resolved it with changing to r/w ?

#15 Updated by M S about 3 years ago

Hello,

anyone here who reported the same issue and managed to resolve it based on Chris' advice (mount rw) ?

#16 Updated by Ken Thieme about 3 years ago

I mounted rw and the issue is addressed for me. pkg update via shell updated the package repository. Update check is now successful in the dashboard and Update page now loads. Thanks Chris!

#17 Updated by Chris Buechler about 3 years ago

  • Status changed from Confirmed to Resolved

The issue I turned this into is now fixed by fixing #6184.

M S: if you're still having issues permanently rw mounted, including after a reboot after setting it that way, there is something else going on in that case and I hijacked this to be something different. Since subject issue is fixed and this has been referenced in multiple places as such, marking this as resolved. Followed up with you on the email thread to see where things stand.

Also available in: Atom PDF