Project

General

Profile

Bug #6209

nano + dashboard - lag issues in UI

Added by James Starowitz almost 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Dashboard
Target version:
-
Start date:
04/19/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

upgraded from 2.2.5 to 2.3, on a factory install the system slower than all getout, ui lag, network lag, appears that top -m io shows mount at MAX io, if i disable the "system information" widget on the dashboard things improve greatly.

further... "obtaining update status" appears to take FOREVER to find an answer, and by forever i mean.... i havent seen it finish yet.

i attempted to reboot with RW fulltime, did not help

Version 2.3-RELEASE (amd64)
built on Mon Apr 11 18:28:29 CDT 2016
FreeBSD 10.3-RELEASE

Obtaining update status

System Netgate APU
Platform nanobsd (4g)
CPU Type AMD G-T40E Processor
2 CPUs: 1 package(s) x 2 core(s)

last pid: 30596; load averages: 0.17, 0.17, 0.10 up 0+02:25:45 17:51:37
47 processes: 1 running, 45 sleeping, 1 zombie
CPU: 0.0% user, 0.0% nice, 0.8% system, 0.6% interrupt, 98.6% idle
Mem: 36M Active, 66M Inact, 166M Wired, 964K Cache, 156M Buf, 1661M Free
Swap:

PID USERNAME   VCSW  IVCSW   READ  WRITE  FAULT  TOTAL PERCENT COMMAND
73807 root 0 0 0 0 0 0 0.00% php-fpm
30352 root 0 0 0 0 0 0 0.00% sh
20254 root 0 0 0 0 0 0 0.00% php-fpm
30275 root 168 0 0 162 0 162 100.00% mount
44736 root 13 4 0 0 0 0 0.00% openvpn
57976 root 18 0 0 0 0 0 0.00% dpinger

History

#1 Updated by James Starowitz almost 3 years ago

i attempted to remove all the widgets, and got some squirrely errors also. apparently that isnt possible?

#2 Updated by James Starowitz almost 3 years ago

changed webui processes from 8 to 2, still having same problem with sys info widget active

#3 Updated by James Starowitz almost 3 years ago

doing a ps auxwwf | grep mount take 6-12 seconds to return the following

[2.3-RELEASE][root@x]/root: ps auxwwf | grep mount
root 59983 0.1 0.1 14416 2012 - D 5:59PM 0:00.06 /sbin/mount -u -r -f -o syn c,noatime /
root 60241 0.0 0.1 18740 2236 0 S+ 5:59PM 0:00.00 grep mount
[2.3-RELEASE][root@x]/root: time ps auxwwf | grep mount
root 69694 0.3 0.1 14416 2012 - D 5:59PM 0:00.06 /sbin/mount -u -r -f -o syn c,noatime /
root 70339 0.0 0.0 392 312 0 R+ 5:59PM 0:00.00 grep mount
[2.3-RELEASE][root@x]/root: time ps auxwwf | grep mount
root 64109 0.1 0.1 14416 2012 - D 6:00PM 0:00.06 /sbin/mount -u -r -f -o sync,noatime /
root 65228 0.0 0.1 18740 2236 0 S+ 6:00PM 0:00.00 grep mount
[2.3-RELEASE][root@x]/root: time ps auxwwf | grep mount
root 83022 0.3 0.1 14416 2012 - D 6:00PM 0:00.06 /sbin/mount -u -r -f -o sync,noatime /
root 83504 0.0 0.0 392 312 0 R+ 6:00PM 0:00.00 grep mount

#4 Updated by James Starowitz almost 3 years ago

maybe if mount wasnt grinding away at 100% cpu for half an hour these wouldnt error either.

Crash report begins.  Anonymous machine information:

amd64
10.3-RELEASE
FreeBSD 10.3-RELEASE #4 05adf0a(RELENG_2_3_0): Mon Apr 11 19:09:19 CDT 2016 root@factory23-amd64-builder:/builder/factory-230/tmp/obj/builder/factory-230/tmp/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[19-Apr-2016 18:25:11 America/New_York] PHP Stack trace:
[19-Apr-2016 18:25:11 America/New_York] PHP 1. {main}() /usr/local/www/index.php:0
[19-Apr-2016 18:25:11 America/New_York] PHP 2. write_config() /usr/local/www/index.php:166
[19-Apr-2016 18:25:11 America/New_York] PHP 3. backup_config() /etc/inc/config.lib.inc:553
[19-Apr-2016 18:25:11 America/New_York] PHP 4. copy() /etc/inc/config.lib.inc:920
[19-Apr-2016 18:25:11 America/New_York] PHP Stack trace:
[19-Apr-2016 18:25:11 America/New_York] PHP 1. {main}() /usr/local/www/index.php:0
[19-Apr-2016 18:25:11 America/New_York] PHP 2. write_config() /usr/local/www/index.php:166
[19-Apr-2016 18:25:11 America/New_York] PHP 3. backup_config() /etc/inc/config.lib.inc:553
[19-Apr-2016 18:25:11 America/New_York] PHP 4. filesize() /etc/inc/config.lib.inc:927
[19-Apr-2016 18:25:11 America/New_York] PHP Stack trace:
[19-Apr-2016 18:25:11 America/New_York] PHP 1. {main}() /usr/local/www/index.php:0
[19-Apr-2016 18:25:11 America/New_York] PHP 2. write_config() /usr/local/www/index.php:166
[19-Apr-2016 18:25:11 America/New_York] PHP 3. backup_config() /etc/inc/config.lib.inc:553
[19-Apr-2016 18:25:11 America/New_York] PHP 4. fopen() /etc/inc/config.lib.inc:928
[19-Apr-2016 18:25:11 America/New_York] PHP Stack trace:
[19-Apr-2016 18:25:11 America/New_York] PHP 1. {main}() /usr/local/www/index.php:0
[19-Apr-2016 18:25:11 America/New_York] PHP 2. write_config() /usr/local/www/index.php:166
[19-Apr-2016 18:25:11 America/New_York] PHP 3. backup_config() /etc/inc/config.lib.inc:553
[19-Apr-2016 18:25:11 America/New_York] PHP 4. fwrite() /etc/inc/config.lib.inc:929
[19-Apr-2016 18:25:11 America/New_York] PHP Stack trace:
[19-Apr-2016 18:25:11 America/New_York] PHP 1. {main}() /usr/local/www/index.php:0
[19-Apr-2016 18:25:11 America/New_York] PHP 2. write_config() /usr/local/www/index.php:166
[19-Apr-2016 18:25:11 America/New_York] PHP 3. backup_config() /etc/inc/config.lib.inc:553
[19-Apr-2016 18:25:11 America/New_York] PHP 4. fclose() /etc/inc/config.lib.inc:930

#5 Updated by James Starowitz almost 3 years ago

(3:18:35 PM) PiBa-NL: systemwidget seems to call conf_mount_rw() 12 times for a single page refresh..
(3:18:46 PM) PiBa-NL: on my full install anyway..
(3:18:52 PM) jstar1: that sounds sub optimal

(3:17:27 PM) jstar1: time to replace the flashcard?

#6 Updated by Chris Buechler almost 3 years ago

  • Status changed from New to Duplicate
  • Target version deleted (2.3.1)
  • Affected Version deleted (2.3)

duplicate of #6184

#7 Updated by James Starowitz almost 3 years ago

diag>nano> enable RW all the time. resolved the issue, apparently the first time it was tried, mount was locking the disks so the webui couldnt write the config, which is why it then turned off RW mode after a reboot.

im sure everybody running stock nano is seeing this horrible performance and lag, you should force all nanos to RW if this is really the solution.

i dont agree that this is a duplicate.

#8 Updated by Chris Buechler almost 3 years ago

#6184 is basically "fix the mount issue", so it does cover everything here.

Also available in: Atom PDF