Project

General

Profile

Bug #6212

Update checks being done in the background even when disabled on dashboard

Added by Phillip Davis about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Upgrade
Target version:
Start date:
04/20/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

If "Disable the automatic dashboard auto-update check" is checked in update settings, the code is still doing the check in the background (even though the result is not displayed on the dashboard GUI). This causes problems for people who disabled it because the backgorund processing of the package commands is a problem for whatever reason.
Forum: https://forum.pfsense.org/index.php?topic=110424.0

Associated revisions

Revision d3f7004d (diff)
Added by Phillip Davis about 3 years ago

Fix #6212 Really disable checks

Belts and braces here - I the setTimeout is not done then the other bits of code do not get called anyway, but I took them all out to make sure there is no way to accidentally do the update check when it is disabled.

Revision 048f29dc (diff)
Added by Phillip Davis about 3 years ago

Fix #6212 Really disable checks

Belts and braces here - I the setTimeout is not done then the other bits of code do not get called anyway, but I took them all out to make sure there is no way to accidentally do the update check when it is disabled.
(cherry picked from commit d3f7004d96c274f117a0264094595c9fbe85b6f7)

History

#2 Updated by Phillip Davis about 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Chris Buechler about 3 years ago

  • Status changed from Feedback to Resolved

confirmed, checked prior to update when disabled, doesn't now. Thanks Phil!

Also available in: Atom PDF