Project

General

Profile

Bug #6257

Kernel panic with ALTQ

Added by Ivor Kreso over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Operating System
Target version:
Start date:
04/25/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
amd64

Description

Kernel panic with ALTQ being used on 2.2.6 and now on 2.3. Only happens with ALTQ active, does not happen when the shaper is removed. Confirmed by removing the shaper. Pretty basic setup, no HA. Customer ticket IJF-82101.

I've attached multiple crash dumps, one from 2.2.6 and two once the customer updated to 2.3.

kdump.txt (158 KB) kdump.txt Ivor Kreso, 04/25/2016 07:36 AM
crash report.txt (149 KB) crash report.txt Ivor Kreso, 04/25/2016 07:36 AM
crashdump(1).txt (143 KB) crashdump(1).txt Ivor Kreso, 04/25/2016 07:37 AM
ddb.txt (48 KB) ddb.txt Nash Kaminski, 01/09/2017 06:51 PM

History

#1 Updated by Chris Buechler over 3 years ago

  • Subject changed from Kernel panic with ALTQ - 2.2.6 - 2.3 to Kernel panic with ALTQ
  • Category set to Operating System
  • Status changed from New to Confirmed
  • Affected Version changed from 2.3 to All

#2 Updated by Luiz Souza over 3 years ago

  • Assignee set to Luiz Souza

#3 Updated by Chris Buechler over 3 years ago

  • Target version changed from 2.3.2 to 2.4.0

#4 Updated by Nash Kaminski almost 3 years ago

Also experiencing a very similar crash every few days in the igb driver queue thread after updating to 2.4.0 as long as ALTQ is compiled into the kernel, even without it actively in use. After doing a bit of research into FreeBSD bug reports, this issue in general seems to be related to the following FreeBSD bug: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=213257 Crash dump from 2.4 also attached and the hardware I am running pfSense on is a Supermicro SYS-5018a-MLTN4. No HA features are enabled however multiple VLANs are setup on igb0.

#5 Updated by Luiz Souza over 2 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Fixed in 2.4.

Also available in: Atom PDF