Project

General

Profile

Actions

Bug #643

closed

CARP interfaces aren't created on initial sync

Added by Jim Pingle over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
CARP
Target version:
Start date:
06/10/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

On the first sync of a CARP VIP to a backup host, the settings are copied but the CARP interface is not created.

If you edit/save the VIP, an interface is created as expected. All interfaces are created if you reboot the slave after sync.

Actions #1

Updated by Jim Pingle over 11 years ago

Some more info on how to reproduce this. On a pair of systems already setup for config sync, do the following:

On the Master:
  • Go to Firewall > Virtual IPs
  • Create a new CARP VIP, give it a VHID, password, etc.
  • Save/apply
On the Backup:
  • Go to Status > CARP (Failover)
  • * There is a line for the new IP, but no interface listed
  • Look at ifconfig -a
  • * There is no VIP interface for this new CARP IP
  • Go to Firewall > Virtual IPs
  • Edit the new CARP IP
  • Change nothing, just Save/Apply
  • Look at Status > CARP and ifconfig -a
  • * VIP interface is present with a proper name and working as expected.
Actions #2

Updated by Jim Pingle over 11 years ago

  • Status changed from New to Feedback

This should be OK now.

Actions #3

Updated by Chris Buechler over 11 years ago

  • Status changed from Feedback to Resolved

fixed

Actions

Also available in: Atom PDF