Project

General

Profile

Bug #655

Disabling IPsec does not flush SPDs

Added by Jim Pingle almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
IPsec
Target version:
Start date:
06/14/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When you disable IPsec, all SPDs should be flushed or traffic that would have been going across the VPN will still be grabbed even though IPsec is off.

Same goes for disabling an individual tunnel, its SPD entries should be flushed when a single tunnel is disabled/removed.

Associated revisions

Revision 42f4bbd9 (diff)
Added by Ermal Luçi almost 9 years ago

Ticket #655. Call vpn_ipsec_configured in all cases it knows how to handle enabled/disabled ipsec setting.

Revision 98c02cac (diff)
Added by Ermal Luçi almost 9 years ago

Ticket #655. Another try at this.

History

#1 Updated by Chris Buechler almost 9 years ago

This used to work in 2.0 even, for both of the mentioned scenarios. Neither do now.

#2 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

#3 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to New

no change

#4 Updated by Jim Pingle almost 9 years ago

  • Status changed from New to Feedback

Should be fixed by:

https://rcs.pfsense.org/projects/pfsense/repos/mainline/commits/9fad9848c9353b9a21402634a537ae74bd976354

Unless someone has a better suggestion. Without that change, the underlying function doesn't pick up on the config update for some reason.

#5 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF