Project

General

Profile

Bug #6665

Upgrading packages when pfSense upgrade is available breaks package manager

Added by Kill Bill almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
Start date:
07/30/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3.x
Affected Architecture:
All

Description

As described here: https://forum.pfsense.org/index.php?topic=116026.0 - when you upgrade some package before upgrading pfSense, pkg gets upgraded first - and things get badly screwed, rendering the GUI package manager unusable.

While this gets fixed eventually after you upgrade the OS, this certainly is not desirable either way - people may have valid reason to not upgrade the base OS just yet; plus such issue should not happen in the first place.

History

#1 Updated by Kill Bill almost 3 years ago

(Same goes for merely installing a package, not just upgrading.)

#2 Updated by Jim Pingle almost 3 years ago

  • Priority changed from High to Normal

In this case it actually turns out that the problem is the new version of 'pkg' needs a different command line parameter when it is called the way the GUI requires. It's easy to work around, though. Especially if you have the System Patches package already installed

If you need to install the System Patches package, you can do so from the command line:

pkg install pfSense-pkg-System_Patches

Once that is installed, add an entry in the System Patches package for f3f59e4aa40093093c5593fbe3e42335441276e1 and then fetch/apply.

Or look at the commit and make the (very small) change by hand.

It would still be nice to have a small pkg or way to update some code to handle pkg changes like this more smoothly in the future.

#3 Updated by Kill Bill almost 3 years ago

Noticed a lot of complaints on the forums as well in many different threads. Wouldn't locking the pkg package itself (like you lock the kernel) work to prevent this from happening again?

#4 Updated by Jim Pingle almost 3 years ago

I'm not sure that would be viable but Renato would know better than I. You have to upgrade pkg to the new version to read the newer pkg data from our servers and reach the target version when upgrading, it may also affect the other pkg repos as well.

#5 Updated by Renato Botelho almost 3 years ago

  • Status changed from New to Feedback
  • Target version set to 2.3.2-p1
  • % Done changed from 0 to 100

I've pushed a fix for that, it's in pkg-1.8.7_1

#6 Updated by Jim Pingle almost 3 years ago

  • Status changed from Feedback to Resolved

Fix works fine, the older release is no longer broken by the newer pkg.

If you have a system stuck in the older state, run:

pkg update; pkg upgrade pkg

#7 Updated by Kill Bill almost 3 years ago

+1, tested and working, thanks. ;)

Also available in: Atom PDF