Project

General

Profile

Actions

Bug #6667

closed

DHCP DUID file not preserved across reboots when "Use RAM Disks" is enabled

Added by Gary Dezern almost 6 years ago. Updated almost 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
07/30/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

The file "/var/db/dhcp6c_duid" contains a DHCP Unique Identifier (DUID) that a host uses to uniquely identify itself to a DHCPv6 server. According to RFC6355 (https://tools.ietf.org/html/rfc6355), "DUIDs are intended to remain constant over time, so that they can be used as permanent identifiers for a device."

This is not working properly in pfSense 2.3.2-RELEASE if the option for "Use RAM Disks" is selected in "System->Advanced->Miscellaneous." In this case, it appears that the duid file is not preserved before a shutdown, and therefore regenerated on each startup. As a result, a DIFFERENT DUID is created, and the system appears to be a different device to a DHCPv6 server.

This file should either NOT be stored in /var, or be preserved across reboots in a manner similar to how RRD and DHCP Leases are preserved.

Actions #1

Updated by Kill Bill almost 6 years ago

Duplicate of https://redmine.pfsense.org/issues/3971 (this is a more generic problem, even without tmpfs-based /var, plus having this set in stone is not desirable either).

Actions #2

Updated by Jim Pingle almost 6 years ago

  • Status changed from New to Duplicate

Duplicate of #3971

Actions #3

Updated by Gary Dezern almost 6 years ago

This is NOT a duplicate. While 3971 might resolve this bug as a side effect, a fix for this bug might not fulfill the request made by 3971.

Oh, and I included the wrong RFC above. For an in-depth discussion (including the proper RFC's and quotes from them), please see: https://forum.pfsense.org/index.php?topic=116038.msg644172#msg644172

... I guess there's no way to remove the "duplicate" flag at this point? Should I enter a new ticket?

Actions #4

Updated by Jim Pingle almost 6 years ago

This is a symptom/byproduct of the other missing feature, so it is definitely a duplicate. Solve the other, and this is solved. There would be no reason to solve this one instead of the other.

Actions #5

Updated by Gary Dezern almost 6 years ago

Well, you're running it, so I won't argue (too much.) ;)

Actions

Also available in: Atom PDF