Project

General

Profile

Bug #667

dial on demand broken again

Added by Bipin Chandra almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
06/16/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

dial on demand doesnt seem to work again for pppoe, i have that tick and now if i go to interfaces and click disconnect then the interface is not brought up again automatically if traffic is generated

Associated revisions

Revision a138f4fb (diff)
Added by Ermal Luçi almost 9 years ago

Fixes #667. Do not bring down mpd5 if the interface is configured for dial on-demand.

Revision 64e6490a (diff)
Added by Ermal Luçi almost 9 years ago

Ticket #667. Take another approach at handling dial-on-demand and Connect/Disconnect button. If the link is chosen for dial on demand during a disconnect request it will be brough up again instead of just leaving it down so traffic will flow easily when there is a request.

Revision 5c49cf58 (diff)
Added by Ermal Luçi almost 9 years ago

Ticket #667. Actually destroy when trying to reconfigure an interface.

History

#1 Updated by Chris Buechler almost 9 years ago

  • Category set to Interfaces
  • Target version set to 2.0

#2 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

#3 Updated by Ermal Luçi almost 9 years ago

  • % Done changed from 0 to 100

#4 Updated by Bipin Chandra almost 9 years ago

tested it with the latest snap with the patch, now another issue has popped up, if u go to interface and click disconnect then it doesn't seem to get the connection down at all so basically i wasn't able to test auto reconnect that way so i tried pulling the lan cable from it and it still seems to shows the old ip etc under interface and system log only shows vr1 down and plugging it back in just shows vr1 up but doesn't seem to issue a new ip or something like that so basically the ip remains the same and for some reason clients r able to surf again

#5 Updated by Bipin Chandra almost 9 years ago

and an update on it, on click disconnect from interfaces, the gateway is lost but conenction still up so this keeps coming in systemlog

Jun 17 14:30:02 php: : Could not find gateway for interface(wan).
Jun 17 14:30:03 last message repeated 3 times

but itnernet seems to work

#6 Updated by Marcus Brown almost 9 years ago

Before Ermal applied changeset a138f4fbc077f89ff413355ba738e00d36317973 the disconnect button did one thing for all types of mpd5 connections and that was to kill the mpd5 process for that link. Now, the changeset causes the disconnect button to do nothing when Dial-on-demand is checked. The button kills the process or doesn't kill the process, but it can't do both. :)

So, there needs to be a "the behavior is to kill the process, or the behavior is to do nothing" decision about this issue. It is possible to do some more complicated coding so that the disconnect brings down the link without killing mpd5 process, but I doubt that is in anyone's list of priorities because is is just not important as far as I can tell to be able to bring down a link with dial on demand configured in a way that doesn't kill the mpd5 process. That's what the "timeout" setting is for.

#7 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to New

#8 Updated by Bipin Chandra almost 9 years ago

in spite of dial on demand being ticked, the older snaps at least used to disconnect the the line and then due to dial on demand being ticked, reattempt connection, this way the client can get a renewed ip from his pppoe connection from his isp or else there would be no way to renew the ip other than restart pfsense completely.

as the tick box says, dial on demand, meaning if the connection is down and a connection is demanded, then dial out, it doesn't say, don't allow disconnection.

#9 Updated by Ermal Luçi almost 9 years ago

I actually will revert that changeset if you do not make up your mind.
Seems i have misread the bug before and if you click disconnect in status -> Interfaces the interface has to be/stay down since that is an administrator utility.

This will restore the full functionality back of bringing up/down from events and dial-on-demand will work as long as no events happen.

Timeout 2 days.

#10 Updated by Bipin Chandra almost 9 years ago

what im trying to tell u is in older snaps dial on demand as well as disconnect used to work together as well as in 1.2.3, the benefit of dial on demand is if connection dropped for some other reason then it would reconnect automatically and the benefit of disconnect button was to be able to renew the IP from isp if there was some issue so on clicking that, it would disconnect completely and due to dial on demand it would reconnect automatically but currently if dial on demand is ticked then disconnect doesn't do anything and if its unticked then it just disconnects so basically both the purposes r not fulfilled like it used to in 1.2.3 as well as older 2.0.

cant it be done such that on clicking disconnect a event is generated which disconnects and dial on demand detects this and then tries to reconnect a fresh connection?

#11 Updated by Marcus Brown almost 9 years ago

pfsense behaves by default (without dial-on-demand ticked) as you stated above ( "if connection dropped for some other reason then it would reconnect automatically and the benefit of disconnect button was to be able to renew the IP from isp if there was some issue").

You do not need dial-on-demand to get the behavior you want. It's already built in.

#12 Updated by Bipin Chandra almost 9 years ago

it might be but there have been a few rare cases in which i got disconnected from the isp which usually doesn't happen and with the dial on demand unticked, the pppoe connection wasn't reconnected until clients started complaining of internet being down so i had to manually click the connect button on the interfaces page to make it connect so i then ticked dial on demand but now i am unable to make any use of the disconnect button.

if u think the current behavior is as intended and have been tested then u might as well close this bug and forget about it and move on with other important issues.

#13 Updated by Pho Bia almost 9 years ago

Has this been addressed in a recent snapshot? I am also still seeing this behavior with "2.0-BETA3
built on Tue Jul 13 22:32:04 EDT 2010".

-- Phob

#14 Updated by Ermal Luçi almost 9 years ago

Please try the behaviour on last snapshots.

#15 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

#16 Updated by Bipin Chandra almost 9 years ago

works fine now

#17 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

#18 Updated by Pho Bia almost 9 years ago

Hi there,

I have tested this, and something still isn't working correctly.

I have 3 WAN interfaces, two of which are PPPoE (PPPoE0 & PPPoE1) and if I click disconnect on PPPoE1 it causes PPPoE0 to disconnect as well. PPPoE0 then seems to reconnect itself (with a new IP), and PPPoE1 remains disconnected.

If I disconnect PPPoE0, PPPoE1 remains connected as expected.

-- Phob

#19 Updated by Pho Bia almost 9 years ago

Hello again,

I don't know if this is related or not, but I also notice that the corresponding Gateway for any disconnected PPPoE interface shows offline until I manually go into each and click save then apply changes.

This issue impacts my Gateway Groups for outbound load balancing.

-- Phob

#20 Updated by Chris Buechler almost 9 years ago

Phob: that's different, open a new ticket with specifics on replicating

Also available in: Atom PDF