Project

General

Profile

Actions

Bug #6801

closed

Rule separators are moving when multiple firewall rules are deleted together

Added by TCI User about 5 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
09/21/2016
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3.2
Affected Architecture:
amd64

Description

Steps to reproduce:

1. Select multiple firewall rules
2. Delete together
3. The rule separators changed their position

IMPORTANT NOTE: Only the separators below the deleted firewall rules are moving.


Files

A1.jpg (117 KB) A1.jpg Select multiple firewall rules and delete together TCI User, 09/21/2016 08:27 AM
A2.jpg (90.8 KB) A2.jpg The rule separators changed their position TCI User, 09/21/2016 08:27 AM
Actions #1

Updated by Steve Beaver about 5 years ago

  • Assignee set to Steve Beaver
Actions #2

Updated by Steve Beaver about 5 years ago

  • Status changed from New to Feedback
  • Assignee changed from Steve Beaver to TCI User

Fixed and tested. Please confirm.

Actions #3

Updated by Steve Beaver about 5 years ago

  • % Done changed from 0 to 100
Actions #4

Updated by TCI User about 5 years ago

Steve Beaver wrote:

Applied in changeset 00098bc80b6f85eb74f2f3bc2b4eb7430614110d.

Steve, would you provide me with basic instructions on how to apply the change so I can test it?

I already have the System_Patches package installed.

Thanks,
Slav

Actions #5

Updated by Steve Beaver about 5 years ago

Probably easiest to just wait from the next snapshot and update. Alternatively you could access the updated file here: https://github.com/pfsense/pfsense/blob/master/src/usr/local/www/firewall_rules.php and copy/paste it into your pfSense installation using Diagnostics -> Edit file.

Actions #6

Updated by Jim Pingle about 5 years ago

The wiki doc for the System Patches package explains how to use the commit ID from the above comment to apply the patch: https://doc.pfsense.org/index.php/System_Patches

Actions #7

Updated by TCI User about 5 years ago

Thank you Steve / Jim.

I found it safer to apply the changes through Diagnostics -> Edit file.

Confirming that firewall_rules.php works fine and the separators do not move.

Please apply the change and to firewall_nat.php

Regards,
Slav

Actions #8

Updated by Steve Beaver about 5 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 2.3.2-p1

Thanks for confirming. Fix has now been applied to firewall_nat.php as well.

Actions #9

Updated by Max Frames almost 2 years ago

It seems that the bug has returned, as I just had this exact issue when deleting multiple firewall rules with version 2.4.4-RELEASE-p3 (amd64).

Actions #10

Updated by Jim Pingle almost 2 years ago

I couldn't reproduce the exact same bug stated here, but I did manage to reproduce a similar one. I opened #9887 and added details there.

Actions

Also available in: Atom PDF