Project

General

Profile

Bug #684

interface status, disconenct button doesnt work

Added by Bipin Chandra almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
06/22/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

disconnect button under status > interfaces doesnt work for pppoe connections, on clicking it, the pppoe conenction isnt disconencted, the gateway address seems to disappear but pppoe is still connected and if u check under status > gateways, the gteway ip is no more in list, but main concern is that pppoe is never disconencted.

Associated revisions

Revision 8d9cbe6f (diff)
Added by Ermal Luçi almost 9 years ago

Fixes #684. Test file existence before trying to kill the process. Also correct interface name passed as parameter to interface_configure function, it should fix another ticket as a byproduct.

Revision 003f291a (diff)
Added by Ermal Luçi almost 9 years ago

Ticket #684. Actually when reconfiguring an interface send the destory flag to avoid a loop with ppp-on-demand.

Revision dea80743 (diff)
Added by Ermal Luçi almost 9 years ago

Ticket #684. Dispatch the reloading of the interface in dial-on-demand case to easy the GUI responsivess.

History

#1 Updated by Ermal Luçi almost 9 years ago

Have you checked dial-on-demand?
Any entries in the system log?

Please can you provide the output of commands:
ifconfig
ps -ax | grep mpd5

#2 Updated by Bipin Chandra almost 9 years ago

dial on demand is checked but in older snaps, on clicking disconnect, pppoe used to disconnect and due to dial on demand it used to again attempt connection but currently no entries in system log nor any attempt to disconnect or reconnect.

BEFORE DISCONNECT IS PRESSED
----------------------------

$ ifconfig
vr0: flags=8b43<UP,BROADCAST,RUNNING,PROMISC,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=82808<VLAN_MTU,WOL_UCAST,WOL_MAGIC,LINKSTATE>
ether 00:0d:b9:13:47:84
inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255
inet6 fe80::20d:b9ff:fe13:4784%vr0 prefixlen 64 scopeid 0x1
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
vr1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8280b<RXCSUM,TXCSUM,VLAN_MTU,WOL_UCAST,WOL_MAGIC,LINKSTATE>
ether 00:0d:b9:13:47:85
inet6 fe80::20d:b9ff:fe13:4785%vr1 prefixlen 64 scopeid 0x2
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
vr2: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8280b<RXCSUM,TXCSUM,VLAN_MTU,WOL_UCAST,WOL_MAGIC,LINKSTATE>
ether 00:0d:b9:13:47:86
media: Ethernet autoselect (none)
status: no carrier
ath0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
ether 00:80:48:60:7b:07
media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
status: running
pflog0: flags=100<PROMISC> metric 0 mtu 33200
enc0: flags=0<> metric 0 mtu 1536
pfsync0: flags=0<> metric 0 mtu 1460
syncpeer: 224.0.0.240 maxupd: 128
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=3<RXCSUM,TXCSUM>
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x8
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
ath0_wlan0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 00:80:48:60:7b:07
inet6 fe80::280:48ff:fe60:7b07%ath0_wlan0 prefixlen 64 scopeid 0x9
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
status: running
ssid "1mbps Blazing" channel 6 (2437 MHz 11g) bssid 00:80:48:60:7b:07
regdomain NONE country AE ecm authmode WPA privacy MIXED deftxkey 3
AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 30 scanvalid 60 pureg
protmode RTSCTS wme burst dtimperiod 1 -dfs
pppoe0: flags=8ad1<UP,POINTOPOINT,RUNNING,NOARP,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1492
inet 92.99.149.77 --> 195.229.252.33 netmask 0xffffffff
inet6 fe80::20d:b9ff:fe13:4784%pppoe0 prefixlen 64 scopeid 0xa
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether d2:f4:95:96:44:3e
id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
member: ath0_wlan0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 9 priority 128 path cost 370370
member: vr0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 1 priority 128 path cost 200000

$ ps -ax | grep mpd5
6116 ?? Ss 0:00.22 /usr/local/sbin/mpd5 -b -k -d /var/etc -f mpd_wan.con
52621 ?? S 0:00.01 sh -c ps -ax | grep mpd5
52816 ?? S 0:00.01 grep mpd5

AFTER DISCONNECT IS PRESSED
---------------------------
$ ifconfig
vr0: flags=8b43<UP,BROADCAST,RUNNING,PROMISC,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=82808<VLAN_MTU,WOL_UCAST,WOL_MAGIC,LINKSTATE>
ether 00:0d:b9:13:47:84
inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255
inet6 fe80::20d:b9ff:fe13:4784%vr0 prefixlen 64 scopeid 0x1
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
vr1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8280b<RXCSUM,TXCSUM,VLAN_MTU,WOL_UCAST,WOL_MAGIC,LINKSTATE>
ether 00:0d:b9:13:47:85
inet6 fe80::20d:b9ff:fe13:4785%vr1 prefixlen 64 scopeid 0x2
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
vr2: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8280b<RXCSUM,TXCSUM,VLAN_MTU,WOL_UCAST,WOL_MAGIC,LINKSTATE>
ether 00:0d:b9:13:47:86
media: Ethernet autoselect (none)
status: no carrier
ath0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
ether 00:80:48:60:7b:07
media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
status: running
pflog0: flags=100<PROMISC> metric 0 mtu 33200
enc0: flags=0<> metric 0 mtu 1536
pfsync0: flags=0<> metric 0 mtu 1460
syncpeer: 224.0.0.240 maxupd: 128
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=3<RXCSUM,TXCSUM>
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x8
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
ath0_wlan0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 00:80:48:60:7b:07
inet6 fe80::280:48ff:fe60:7b07%ath0_wlan0 prefixlen 64 scopeid 0x9
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
status: running
ssid "1mbps Blazing" channel 6 (2437 MHz 11g) bssid 00:80:48:60:7b:07
regdomain NONE country AE ecm authmode WPA privacy MIXED deftxkey 3
AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 30 scanvalid 60 pureg
protmode RTSCTS wme burst dtimperiod 1 -dfs
pppoe0: flags=8ad1<UP,POINTOPOINT,RUNNING,NOARP,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1492
inet 92.99.149.77 --> 195.229.252.33 netmask 0xffffffff
inet6 fe80::20d:b9ff:fe13:4784%pppoe0 prefixlen 64 scopeid 0xa
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether d2:f4:95:96:44:3e
id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
member: ath0_wlan0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 9 priority 128 path cost 370370
member: vr0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 1 priority 128 path cost 200000

$ ps -ax | grep mpd5
6116 ?? Ss 0:00.22 /usr/local/sbin/mpd5 -b -k -d /var/etc -f mpd_wan.con
12690 ?? S 0:00.01 sh -c ps -ax | grep mpd5
12843 ?? S 0:00.01 grep mpd5

#3 Updated by Bipin Chandra almost 9 years ago

one step i do to get over this is as follow:

on clickign disconnect nothing happens even after a few mins so i go to system > routing and in the list it shows the GW_WAN so i simply click edit and press apply without changing anything and then a reconenct is attepted and system log shows below stuff

Jun 22 14:01:54 syslogd: kernel boot file is /boot/kernel/kernel
Jun 22 14:02:03 dhcpd: Internet Systems Consortium DHCP Server V3.0.7
Jun 22 14:02:03 dhcpd: Copyright 2004-2008 Internet Systems Consortium.
Jun 22 14:02:03 dhcpd: All rights reserved.
Jun 22 14:02:03 dhcpd: For info, please visit http://www.isc.org/sw/dhcp/
Jun 22 14:02:07 dnsmasq24013: reading /etc/resolv.conf
Jun 22 14:02:07 dnsmasq24013: using nameserver 8.8.4.4#53
Jun 22 14:02:07 dnsmasq24013: using nameserver 8.8.8.8#53
Jun 22 14:02:07 dnsmasq24013: using nameserver 213.42.20.20#53
Jun 22 14:02:07 dnsmasq24013: using nameserver 195.229.241.222#53
Jun 22 14:02:10 check_reload_status: reloading filter
Jun 22 14:02:12 php: : Could not find gateway for interface(wan).
Jun 22 14:02:12 last message repeated 3 times
Jun 22 14:02:25 check_reload_status: rc.newwanip starting
Jun 22 14:02:27 php: : rc.newwanip: Informational is starting .
Jun 22 14:02:34 check_reload_status: syncing firewall
Jun 22 14:02:35 check_reload_status: reloading filter
Jun 22 14:02:38 dnsmasq24013: reading /etc/resolv.conf
Jun 22 14:02:38 dnsmasq24013: using nameserver 8.8.4.4#53
Jun 22 14:02:38 dnsmasq24013: using nameserver 8.8.8.8#53
Jun 22 14:02:38 dnsmasq24013: using nameserver 213.42.20.20#53
Jun 22 14:02:38 dnsmasq24013: using nameserver 195.229.241.222#53
Jun 22 14:02:40 check_reload_status: updating dyndns
Jun 22 14:02:42 php: : DynDns: Running updatedns()
Jun 22 14:02:42 php: : DynDns: updatedns() starting
Jun 22 14:02:42 php: : DynDns: _detectChange() starting.
Jun 22 14:02:42 php: : DynDns: _checkIP() starting.
Jun 22 14:02:42 php: : DynDns debug information: 94.59.216.203 extracted from local system.
Jun 22 14:02:42 php: : DynDns: Current WAN IP: 94.59.216.203
Jun 22 14:02:42 php: : DynDns: Cached IP: 94.59.240.211
Jun 22 14:02:42 php: : DynDns debug information: DynDns: cacheIP != wan_ip. Updating. Cached IP: 94.59.240.211 WAN IP: 94.59.216.203
Jun 22 14:02:42 php: : DynDns: DynDns _update() starting.
Jun 22 14:02:43 php: : DynDns: DynDns _checkStatus() starting.
Jun 22 14:02:43 php: : DynDns: Current Service: dyndns
Jun 22 14:02:43 php: : DynDns: _checkIP() starting.
Jun 22 14:02:43 php: : DynDns debug information: 94.59.216.203 extracted from local system.
Jun 22 14:02:43 php: : phpDynDNS: updating cache file /conf/dyndns_wandyndns.cache: 94.59.216.203
Jun 22 14:02:44 php: : phpDynDNS: (Success) IP Address Changed Successfully! (94.59.216.203)

#4 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

Please check with new snapshots.

#5 Updated by Bipin Chandra almost 9 years ago

works fine now

#6 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

thanks for reporting back.

#7 Updated by Bipin Chandra almost 9 years ago

upgraded from 22nd july nanobsd to 31st july nanobsd and disconnect button is broken again, might not be disconnect button but recent changes to pppoe or itnerface caused it, now when alix boots, pppoe connects fine on boot but suppose if there is a disconenct from isp or u pull the cable out or u click the disconnect button, the connection is not brought up again and there is a endless loop of the below warnings causing the webgui to be unusable.

happens even if u got to wan under interfaces and make some changes or simply click save and then apply it and that would be the end of the wan connection till alix is rebooted

Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70
Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70
Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70

#8 Updated by Bipin Chandra almost 9 years ago

on further investigation, the wan interface page, period reset and dial on demand all r affected

#9 Updated by Chris Buechler almost 9 years ago

  • Status changed from Resolved to New

#10 Updated by Bipin Chandra almost 9 years ago

i tried to trace the changes between 22nd july to 31st july but wasnt able to find whats causing this pppoe reconenct issue due to pppoe_wan.pid file not being found but the file exists and contents r also fine.

could some1 fix this so i can try latest snaps to provide feedback on other issues?

#11 Updated by Bipin Chandra almost 9 years ago

to further narrow this down, i upgraded to the 30th july snap (pfSense-2.0-BETA4-1g-20100730-1433-nanobsd-upgrade.img.gz) and after the first reboot, i went to interfaces and clicked disconnect and only once i got the same warning
Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70
then i got a php warning like output headers sent before .....

then i rebooted the alix again and after that now when i press disconnect, those messages dont appear and works as intended and the first time with the messages also, it went on with the disconnect and reconnect procedure compared to the 31st snap which just goes in the loop of trying to reconnect but making everything unusable.

#12 Updated by Bipin Chandra almost 9 years ago

all snaps from 31st july to 5th august keep giving this in browser in a endless loop when disconnect button is pressed

Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70
Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70
Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70

pppoe is disconnected but then never connected

#13 Updated by Bipin Chandra almost 9 years ago

all snaps from 31st july to 5th august keep giving this in browser in a endless loop when disconnect button is pressed

Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70
Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70
Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70

pppoe is disconnected but then never connected

#14 Updated by Bipin Chandra almost 9 years ago

still the same with the 7th august snap, if some1 could fix this minor issue, just caused by some php warning

#15 Updated by Chris Buechler almost 9 years ago

  • Category set to Interfaces

#16 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

#17 Updated by Ermal Luçi almost 9 years ago

  • % Done changed from 0 to 100

#18 Updated by Bipin Chandra almost 9 years ago

still not solved, as a matter of fact its gone more worse. Now either if u got to the wan interface page and click save and apply or go to interfaces under status and click disconnect, what actually happens is, the pppoe is disconnected but now due to the patch, the php warning doesnt come but complete webgui freezes and pfsense becomes unusable untill a reboot and there is no way to know also what error occurred.

#19 Updated by Ermal Luçi almost 9 years ago

Can i have your config and the system logs after the webgui freezes?

#20 Updated by Bipin Chandra almost 9 years ago

  • File config-firewall.pfsense-20100811195022.xml added

config attached, kindly delete once u get a look at it.

how to get the logs once webgui freezes, i mean using ssh etc can u tell me where its located so i can login into console etc or any other way get it to reveal more details?

#21 Updated by Bipin Chandra almost 9 years ago

after clicking disconnect, below r the details of system log and ppp log

system log shows
----------------
Aug 12 11:43:03 syslogd: kernel boot file is /boot/kernel/kernel
Aug 12 11:43:16 login: login on console as root
Aug 12 11:43:16 sshlockout48578: sshlockout v(null) starting up
Aug 12 11:43:16 sshlockout48578: sshlockout v(null) starting up
Aug 12 11:44:30 login: login on console as root
Aug 12 11:44:42 dnsmasq25597: reading /etc/resolv.conf
Aug 12 11:44:42 dnsmasq25597: using nameserver 8.8.4.4#53
Aug 12 11:44:42 dnsmasq25597: using nameserver 8.8.8.8#53
Aug 12 11:44:42 dnsmasq25597: using nameserver 213.42.20.20#53
Aug 12 11:44:42 dnsmasq25597: using nameserver 195.229.241.222#53
Aug 12 11:45:28 login: login on console as root
Aug 12 11:46:19 kernel: vr2: link state changed to DOWN
Aug 12 11:46:42 kernel: pid 24155 (php), uid 0: exited on signal 11

ppp log shows
-------------
Aug 12 11:43:13 ppp: caught fatal signal term
Aug 12 11:43:13 ppp: [wan] IFACE: Close event
Aug 12 11:43:13 ppp: [wan] IPCP: Close event
Aug 12 11:43:13 ppp: [wan] IPCP: state change Opened --> Closing
Aug 12 11:43:13 ppp: [wan] IPCP: SendTerminateReq #3
Aug 12 11:43:13 ppp: [wan] IPCP: LayerDown
Aug 12 11:43:13 ppp: [wan] IFACE: Down event
Aug 12 11:43:13 ppp: [wan] IPCP: rec'd Terminate Ack #3 (Closing)
Aug 12 11:43:13 ppp: [wan] IPCP: state change Closing --> Closed
Aug 12 11:43:13 ppp: [wan] IPCP: LayerFinish
Aug 12 11:43:13 ppp: [wan] Bundle: No NCPs left. Closing links...
Aug 12 11:43:13 ppp: [wan] Bundle: closing link "wan_link0"...
Aug 12 11:43:13 ppp: [wan_link0] Link: CLOSE event
Aug 12 11:43:13 ppp: [wan_link0] LCP: Close event
Aug 12 11:43:13 ppp: [wan_link0] LCP: state change Opened --> Closing
Aug 12 11:43:13 ppp: [wan_link0] Link: Leave bundle "wan"
Aug 12 11:43:13 ppp: [wan] Bundle: Status update: up 0 links, total bandwidth 9600 bps
Aug 12 11:43:13 ppp: [wan] IPCP: Close event
Aug 12 11:43:13 ppp: [wan] IPCP: Down event
Aug 12 11:43:13 ppp: [wan] IPCP: state change Closed --> Initial
Aug 12 11:43:13 ppp: [wan_link0] LCP: SendTerminateReq #2
Aug 12 11:43:13 ppp: [wan_link0] LCP: LayerDown
Aug 12 11:43:13 ppp: [wan_link0] LCP: rec'd Terminate Ack #2 (Closing)
Aug 12 11:43:13 ppp: [wan_link0] LCP: state change Closing --> Closed
Aug 12 11:43:13 ppp: [wan_link0] LCP: LayerFinish
Aug 12 11:43:13 ppp: [wan_link0] Link: DOWN event
Aug 12 11:43:13 ppp: [wan_link0] LCP: Down event
Aug 12 11:43:13 ppp: [wan_link0] LCP: state change Closed --> Initial
Aug 12 11:43:15 ppp: [wan] Bundle: Shutdown
Aug 12 11:43:15 ppp: [wan_link0] Link: Shutdown
Aug 12 11:43:15 ppp: process 7374 terminated

#22 Updated by Bipin Chandra almost 9 years ago

i got so frustrated with this issue that i did a clean install on another CF card and reconfigured it from scratch and tried it and i got the below message once and same freeze of the webgui
Warning: file_get_contents(/var/run/pppoe_wan.pid): failed to open stream: No such file or directory in /etc/inc/util.inc on line 70
this mde me doubt if the last patch was there in the latest snap and rebooted alix and checked and it seems to have the patch so no clue whats causing the php warning, what i think is some other process or so is locking the pppoe_wan.pid file which exists and consists the pid of mpd and due to the locking, the php scipt is unable to access it and so the above php warning and so the pppoe is never brought up again.

#23 Updated by Bipin Chandra almost 9 years ago

any1 else having this issue?

#24 Updated by Bipin Chandra almost 9 years ago

im on the latest snap and still issues with this, further testing results below:

1) on reboot pppoe conencts fine.

2) if u go to interfaces->wan then click asave and apply then conenction brought down but never gets up till php timeout occurs after which only the webgui is usable again, system log and ppp log dont show anything after mpd process termination so no idea what goes on.

3) if u go to interfaces->wan->advanced and mlpp and then click save then conenction is brough down and up successfully.

4) if u go to status->interfaces and click disconenct then pppoe is disconnected but never got up again and webgui is only usable after php timeout occurs then going to same and clicking conenct enver gets the connection up.

in all cases dial on demand is enabled but disabling also doesnt change any of the above scenarios. last working snap was of 30th august.

#25 Updated by Bipin Chandra almost 9 years ago

there is some correction

all above scenario work fine if dial on demand is disabled and dont work if its enabled.

#26 Updated by Ermal Luçi almost 9 years ago

  • File deleted (config-firewall.pfsense-20100811195022.xml)

#27 Updated by Ermal Luçi almost 9 years ago

Latest snapshot should be ok, i found where the loop was occuring.

#28 Updated by Bipin Chandra almost 9 years ago

now atleast with dial on demand ticked, the pppoe is disconnected and reconnected and receives new ip from isp but the webgui has some issue coz as soon as disconnect is pressed, the page just keeps showing loading and never ends, its suppsoed to return to interface page and even if u goto interfaces->wan and make some changes and click save and then apply, then also page keeps showing loading but never ends, in the abckend the pppoe is brought down and up again sccessfully, so in this case then browsers stop button needs to be pressed then only the webgui is reusable,

#29 Updated by Ermal Luçi almost 9 years ago

The GUI should respond now properly with the latest snapshot.

#30 Updated by Bipin Chandra over 8 years ago

im on the 21st snap and still after clicking disconnect, the page just keeps showing loading whereas the pppoe is already brought down and up again.

#31 Updated by Bipin Chandra over 8 years ago

seems to work fine on the latest snap.

#32 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF