Project

General

Profile

Bug #705

setup_microcode() / enable_hardware_offloading() logic issue

Added by Jim Pingle about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
Start date:
06/28/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

setup_microcode() loops through interfaces by name (WAN, LAN, etc) and calls enable_hardware_offloading() on each entry in the list. The problem is that if WAN, LAN, etc are pppoe, vlan, or other named interfaces, this will not have the desired effect. (VLAN type interfaces are skipped entirely in enable_hardware_offloading(), for instance).

setup_microcode() probably needs to be changed to instead loop over all physical interfaces instead of logical interfaces, since that is where these options need to be set.

Associated revisions

Revision 929a1b15 (diff)
Added by Jim Pingle about 9 years ago

Use the real interface list in setup_microcode() Fixes #705

History

#1 Updated by Jim Pingle about 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF