Project

General

Profile

Bug #72

Configured static routes are not re-added when link from LB Pool goes down then up

Added by GS FON almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/01/2009
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

The routes table is not acting proper when links from pool goes down then up (with new ip).

History

#1 Updated by Seth Mos almost 10 years ago

If I understand this correctly, when a link goes physically down, freebsd will reset the routing table.
When the link comes back up the static routes need to be added again.

I think I removed the system_routing() function in the rc.newwanip at the time as it caused the filter reloads to get stuck in a loop. This was caused by apinger writing out it's configuration and immediately causing a filter reload which can be caused when a member is moving.

#2 Updated by GS FON almost 10 years ago

Seth Mos wrote:

If I understand this correctly, when a link goes physically down, freebsd will reset the routing table.
When the link comes back up the static routes need to be added again.

I think I removed the system_routing() function in the rc.newwanip at the time as it caused the filter reloads to get stuck in a loop. This was caused by apinger writing out it's configuration and immediately causing a filter reload which can be caused when a member is moving.

What I am seeing is that the link goes down, and then for some cable modems, I will get an internal ip of 192.168.100.2 but the static route to the monitor IP is not added to the routing table so now all the monitor pings are going out WAN. The system will think WAN2 is up.

In addition, the static routes for DNS entries are not added to the routing tables on link member changes.

#3 Updated by Scott Ullrich almost 10 years ago

Patch added to 7.2 / 2.0 and 8.0 / 2.0 that will prevent FreeBSD from removing the routes associated with a interface that is is down. This should prevent the monitoring ips from being removed, etc ensuring that we can keep correct track of links state.

#4 Updated by Chris Buechler almost 10 years ago

  • Status changed from New to Closed

Closing this as it's a duplicate of #18, which has a better description of the full issue.

Also available in: Atom PDF