Project

General

Profile

Bug #7300

Error displaying selected ICMP types for old rules without ipprotocol

Added by Phillip Davis over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Rules / NAT
Target version:
Start date:
02/22/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3.3
Affected Architecture:

Description

1) Upgrade from a config that has an old rule that:
a) does not have 'ipprotocol' in its config (from the days before ipv4 vs ipv6)
b) uses ICMP with some ICMP types specified
2) Edit the rule

Expected behavior:
The ICMP types listed in the config are selected in the ICMP Types list on the GUI

Actual behavior:
The ICMP Types list in the GUI has nothing selected and defaults to "any"

Thus if the user does not notice and presses save, they lose the previously=selected ICMP types.

Associated revisions

Revision d0e4f627 (diff)
Added by Phillip Davis over 2 years ago

Fix #7300 provide default value for ipprotocol for old rules

Revision 1877e4d9 (diff)
Added by Phillip Davis over 2 years ago

Fix #7300 provide default value for ipprotocol for old rules

Revision 39079706 (diff)
Added by Phillip Davis over 2 years ago

Fix #7300 provide default value for ipprotocol for old rules

History

#2 Updated by Phillip Davis over 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Renato Botelho over 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF