Project

General

Profile

Bug #7423

Special characters in a password cause problems

Added by Davide Cottignoli almost 4 years ago. Updated over 2 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Captive Portal
Target version:
-
Start date:
03/24/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.3_1
Affected Architecture:
amd64

Description

Possible related to bug #6688:
When £ (pound) character is used in a password from an Active Directory account and an authentication request is made from captive portal to a radius server linked with Microsoft Active Directory, the authentication failed with invalid username or password result.

History

#1 Updated by Davide Cottignoli almost 4 years ago

The Captive Portal login page is the default an it is not customized.

#2 Updated by A FL over 2 years ago

It's not a captiveportal issue.

Radius Auth is working fine with £ in the username and/or in the user password. I just checked with a FreeRADIUS server using an SQL database, it's working like a charm for me when using £.

It look like a configuration issue on your RADIUS server.

What's your RADIUS server? Is it FreeRadius?
If yes, are you performing a Kerberos connection to the AD using winbindd/Samba ? or are you using Freeradius LDAP module ?

In all case, i think this issue can be closed : it's not a pfSense Bug.

#3 Updated by Jim Pingle over 2 years ago

  • Status changed from New to Not a Bug

It's entirely possible the changes to the underlying RADIUS code helped here. There was a similar problem in the past with LDAP parameter encoding.

If it works now then there isn't a reason to keep this open. If someone manages to reproduce it we can get more info then.

#4 Updated by Davide Cottignoli over 2 years ago

The issue was reproducible with Microsoft IAS server on old Windows server 2003 but now we have updated the OS to Windows 2016 with, of course, new Radius software and I haven't tested it with the issue reported. If it is in intererest of the community I will report here when possible, otherwise feel free to close it.

Also available in: Atom PDF