Project

General

Profile

Bug #7451

vpn_openvpn_client.php - Fields not hidden/processed correctly in chrome

Added by Chris Linstruth 3 months ago. Updated 8 days ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
OpenVPN
Target version:
Start date:
04/05/2017
Due date:
% Done:

100%

Affected version:
2.3.3_1
Affected Architecture:

Description

In Chrome (Version 57.0.2987.133 (64-bit) Mac tested) when you edit an OpenVPN Client and switch to shared-key mode, when you deselect create a TLS key and paste an existing key there a new key is created anyway on save and overwrites what was pasted there. User must edit, paste key again, and save.

The Peer Certificate Authority field is visible with shared-key selected and hidden when SSL/TLS is selected.

That's all I saw. Might be more.

Also misbehaves in latest 2.4 snapshots.

Associated revisions

Revision dd3c646f
Added by Steve Beaver 2 months ago

Fixed #7451
Revised onchage handlers to obviate need for second click in Chrome on MacOS

Revision 3290b312
Added by Steve Beaver 2 months ago

Fixed #7451
Revised onchage handlers to obviate need for second click in Chrome on MacOS

(cherry picked from commit dd3c646fa5744a550f91524035a92f509d6162cf)

History

#1 Updated by Jim Pingle 2 months ago

  • Category set to OpenVPN
  • Status changed from New to Feedback
  • Assignee set to Jim Pingle

I can't reproduce this at all here.

On 2.3.x the CRL field shows when it shouldn't, but that has been fixed on 2.4.

If I uncheck the box to generate a new shared key and paste a key into the Shared Key box, it retains that key.

The only potential bug I see is when I switch to shared key, the old TLS key field is not hidden, but it should be. But the TLS key field is not the same as the Shared Key field. I pushed a fix for that just now in 8769058

#2 Updated by Chris Linstruth 2 months ago

Hmm. That's frustrating. I know what I saw. Tested multiple times.

Currently when I select SSL/TLS I get the shared key fields. When I select Shared Key I get TLS fields.

There is still something very wrong on Chrome on the Mac.

Actually, when I reduced the text size so I could see more of the page I see what it is doing. When I change the mode from SSL/TLS to Shared key, the fields don't actually change until I click the mode selector again. Same happens the other way. If that is not clear I took a quick screencast that is a little too large to post here just let me know.

That explains it. What was happening is we were changing to Shared Key and not noticing that the displayed fields were still for the TLS key and had not changed to the shared key, pasting into the TLS key field, and a new shared key was generated on save.

#3 Updated by Chris Linstruth 2 months ago

Looks like mode does the right thing on the vpn_openvpn_server.php but dev_mode also requires that second click to update the page.

#4 Updated by Steve Beaver 2 months ago

  • Assignee changed from Jim Pingle to Steve Beaver

#5 Updated by Steve Beaver 2 months ago

I am able to reproduce this on MacOS & Chrome. Looking at it now.

#6 Updated by Steve Beaver 2 months ago

onchange handlers revised to correct this issue

#7 Updated by Steve Beaver 2 months ago

  • % Done changed from 0 to 100

#8 Updated by Chris Linstruth 2 months ago

Testing using system patches on 2.3.3. Looks good for vpn_openvpn_client.php. Still needs a second click for dev_mode on vpn_openvpn_server.php. Can open another redmine for that if you like.

#9 Updated by Steve Beaver 2 months ago

Took care of that one too

#10 Updated by Chris Linstruth 2 months ago

Looks good here. Thank you.

#11 Updated by Jim Pingle 8 days ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF