Project

General

Profile

Feature #7537

Include mellanox mlx4 and mlx5 ethernet driver

Added by Alexandre Paradis almost 3 years ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Hardware / Drivers
Target version:
Start date:
05/10/2017
Due date:
% Done:

100%

Estimated time:

Description

Hello Devs,

I know you guys doesn't like infiniband, but since there is a lot of cheap option with mellanox card, you could include the ethernet driver for both mlx4 and mlx5.

Thanks in advance!

History

#1 Updated by Alexandre Paradis over 2 years ago

edit : It seems it's supported by the freebsd base : https://www.freebsd.org/releases/11.1R/hardware.html#ethernet

The mlx4en(4) driver supports the following network adapters:

Mellanox ConnectX-2 (ETH)

Mellanox ConnectX-3 (ETH)

The mlx5en(4) driver supports 100Gb, 50Gb, 40Gb, 25Gb and 10Gb Ethernet adapters. ConnectX-4 supports:10/20/25/40/50/56/100Gb/s speeds. ConnectX-4 LX supports:10/25/40/50Gb/s speeds (and reduced power consumption) :

Mellanox MCX455A-ECAT

Mellanox MCX456A-ECAT

Mellanox MCX415A-CCAT

Mellanox MCX416A-CCAT

Mellanox MCX455A-FCAT

Mellanox MCX456A-FCAT

Mellanox MCX415A-BCAT

Mellanox MCX416A-BCAT

Mellanox MCX4131A-GCAT

Mellanox MCX4131A-BCAT

Mellanox MCX4121A-ACAT

Mellanox MCX4111A-ACAT

Mellanox MCX4121A-XCAT

Mellanox MCX4111A-XCAT

#2 Updated by Jim Pingle 7 months ago

  • Category set to Operating System

#3 Updated by Jim Pingle 6 months ago

  • Category changed from Operating System to Hardware / Drivers

#4 Updated by Renato Botelho 4 months ago

  • Status changed from New to In Progress
  • Assignee set to Renato Botelho
  • Target version set to 2.5.0

#5 Updated by Renato Botelho 4 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100

Next round of snapshots will have mlx4en/mlx5en support built in pfSense kernel

#6 Updated by Jim Pingle 3 months ago

  • Target version changed from 2.5.0 to 2.4.5

#7 Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Resolved

Drivers are in the kernel on 2.4.5.a.20191218.2354

: sysctl kern.conftxt | grep mlx
device    mlx
device    mlx4
device    mlx4en
device    mlx5
device    mlx5en
device    mlxfw
: pkg info -x base
pfSense-base-2.4.5.a.20191218.2354

Also available in: Atom PDF