Project

General

Profile

Bug #757

PPPoE Disconnect button with multiple PPPoE interfaces

Added by Pho Bia almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
07/25/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Hello,

Chris asked for this be put in a new issue.

Version : 2.0-BETA3
built on Sun Jul 25 00:16:02 EDT 2010

I have 3 WAN connections, two of which are PPPoE interfaces out of a total of 6 interfaces :

EM0 - VDSL_Admin
PPPoE0 (EM0)
EM1 - DSL_Admin
PPPoE1 (EM1)
EM2 - LAN
EM3 - Cable

As of today's snap, I'm able to successfully disconnect a connected PPPoE session from the Interfaces screen using the "Disconnect" button. The last build I had installed from 3 days ago still didn't seem to respond to that button, so this is definitely progress!

The new issue :

If I disconnect PPPoE0, it works as I would expect with only that interface disconnecting (PPPoE1 remains connected), but if I instead disconnect PPPoE1, both PPPoE0 & PPPoE1 disconnect, where I would have expected PPPoE0 to maintain its session.

As I have dynamic addresses this results in two new IPs.

Also, I have 5 Gateways defined under Routing :

GW_WAN
GW_OPT1
GW_OPT2
VDSL_Admin
DSL_Admin

When I disconnect and then reconnect a PPPoE interface, the Gateway shows as Offline under Status-->Gateways. Only after I manually click edit, then save and finally apply changes from the Routing config screen will the affected Gateway correctly show it is Online.

Also, the corresponding Gateway Groups also show that they are offline without this manual intervention.

A reboot also seems to bring all back into order.

Please let me know what other information I can provide.

-- Phob

ppp.log (15.9 KB) ppp.log Snip of PPP.LOG showing the issue Pho Bia, 08/04/2010 04:03 PM

Associated revisions

Revision a8d6ac1a (diff)
Added by Ermal Luçi over 8 years ago

Ticket #757. Use correct pidfile.

History

#1 Updated by Chris Buechler almost 9 years ago

  • Category set to Interfaces

#2 Updated by Ermal Luçi almost 9 years ago

Can you please provide some system logs about this.
I cannot see why this is happening by looking at code!

#3 Updated by Pho Bia almost 9 years ago

Hi there - I can certainly do this, which log do you want/need? (which file catches the interface/gateway issue?)

I'll attach a portion of the ppp.log file right before I clicked disconnect on PPPoE1. As usual, PPPoE0 disconnected (along with PPPoE1) and obtained a new IP.

-- Phob

#4 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

Should be fixed as part of another commit.

Actually when disconnecting PPPoE1 and trying to connect it, the code was wrong and reconfigured only wan.

#5 Updated by Pho Bia over 8 years ago

Hi there,

The disconnect button is broken again. Slightly different behaviour this time.

Status->Interfaces

When I click "Disconnect" on either of my PPPoE interfaces, the interface loses it's IP, but claims 0.0.0.0 as an IP and still indicates it is UP.

The disconnect button never turns back to connect, and nothing short of rebooting the firewall will return the PPPoE interface to a working status.

I've tried disabling and re-enabling the interface(s) as well as opening and re-saving the interface's gateway entry but nothing seems to work.

Thanks!

-- Phob

#6 Updated by Pho Bia over 8 years ago

Hello again,

I heard from gnhb in the forums who indicated this was/is due to my PPPoE interfaces having the "Dial-on-Demand" enabled.

I should note however that I have always had that option selected, and had previously had a working disconnect button under Status-->Interfaces.

As my understanding of the Dial-on-Demand feature was apparently wrong (I thought you needed this ON for "always on" PPPoE connectivity), I'm not really impacted any longer as I have un-ticked this option from my PPPoE interfaces.

Still - it used to work, so I'm not sure if this means that something changed, or if it was actually a bug that it worked for me at all!

Anyway - thanks as always.

-- Phob

#7 Updated by Bipin Chandra over 8 years ago

i have the same problem, with period pppoe reset enabled also, once the connection is brought down, it never gets up, according to logs, it seems the mpd5 daemon cant be exited and then restarted

Oct 13 09:04:26 ppp: Multi-link PPP daemon for FreeBSD
Oct 13 09:04:26 ppp:
Oct 13 09:04:26 ppp: process 60566 started, version 5.5 (root@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org 18:28 11-Oct-2010)
Oct 13 09:04:26 ppp: waiting for process 51186 to die...
Oct 13 09:04:56 ppp: last message repeated 29 times
Oct 13 09:04:56 ppp: can't lock /var/run/pppoe_wan.pid after 30 attempts
Oct 13 09:06:39 ppp: Multi-link PPP daemon for FreeBSD
Oct 13 09:06:39 ppp:
Oct 13 09:06:39 ppp: process 62726 started, version 5.5 (root@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org 18:28 11-Oct-2010)
Oct 13 09:06:39 ppp: waiting for process 51186 to die...
Oct 13 09:06:42 ppp: Multi-link PPP daemon for FreeBSD
Oct 13 09:06:42 ppp:
Oct 13 09:06:42 ppp: process 63461 started, version 5.5 (root@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org 18:28 11-Oct-2010)
Oct 13 09:06:42 ppp: waiting for process 51186 to die...

so after this i goto the shell and kill the mpd5 and then go back to interfaces and click connect coz till its running, it shows as disconnect button on clicking only the above logs keep repeating but the connection isnt able to be brought down and up again.

#8 Updated by Ermal Luçi over 8 years ago

Can you please try with latest version!

#9 Updated by Marcus Brown over 8 years ago

FYI, this behavior and surrounding trouble about the disconnect button is because one user felt that if the "disconnect" button is pressed and the "Dial on Demand" option is selected, that mpd5 should not be shut down, but should go back into the "connection down, but waiting for outbound traffic to create the connection" state, so it was changed. When the "Dial on Demand" option is selected, the new behavior is that mpd5 is restarted.

A side effect is that there is no way to shut down mpd5 from the web GUI if you select "Dial on Demand" for your mpd5 link.

I have a feeling this will forever be a support issue if the behavior is left as it is. I've already responded to two or three forum posts because people (who have "Dial on Demand" selected) can't get mpd5 to actually disconnect.

Also, there is now a 5 second sleep/hang in the GUI when you disconnect any mpd5 connection as a result of this issue.

I vote to override the user request and go back to the old behavior of the button. "Disconnect" shuts down mpd5, and "Connect" starts it. Simple and easy to understand.

#10 Updated by Ermal Luçi over 8 years ago

Committed the last missing fix.
Please test again.

#11 Updated by Pho Bia over 8 years ago

Hi there - I'm still following this issue. I will update to the latest snap when I'm back onsite later today and report back.

-- Phob

#12 Updated by Pho Bia over 8 years ago

I am able to use the disconnect button to stop PPPOE sessions from the Interfaces screen. Thanks.

#13 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF