Project

General

Profile

Bug #7770

php suhosin mdule error in crash report every boot on latest 2.4 snapshot

Added by Chris Collins about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/12/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4
Affected Architecture:
amd64

Description

I updated today to snapshot 20170812.0957

This error persists on every boot as a crash report

PHP Errors:
[12-Aug-2017 17:14:43 Europe/London] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/suhosin.so' - /usr/local/lib/php/20131226/suhosin.so: Undefined symbol "ps_globals" in Unknown on line 0

History

#1 Updated by Chris Collins about 2 years ago

I have since clean installed the latest snapshot and the problem is gone, so it looks like the problem was a failure in the update process rather than the snapshot itself, please close this.

#2 Updated by Jim Pingle about 2 years ago

  • Status changed from New to Feedback

Do you happen to recall which snapshot you were on before that update?

#3 Updated by Chris Collins about 2 years ago

I believe it was in january but it may have been february as I have this image still on my hdd.

pfSense-CE-2.4.0-BETA-amd64-20170227-0208.iso

So it was quite a jump on the update.

#4 Updated by Jim Pingle about 2 years ago

  • Status changed from Feedback to Resolved

OK. Coming from one that old it's a bit more unpredictable. Some errors are expected due to library changes, PHP may give errors during shutdown when things fail at that time, but it would come up OK. Errors in the crash reporter would still show, but not from the active boot. Only time to worry would be if the errors came back after clearing them from the crash reporter.

Still, with a big jump like that during a development cycle, a fresh install is probably better.

#5 Updated by Chris Collins about 2 years ago

they did come back after it was cleared, but I think as you said since it was half a year ago and its gone now on the reinstall I dont think its an issue.

Also available in: Atom PDF