Project

General

Profile

Bug #7771

domain missing in reverse lookup of host overrides

Added by Richard van Dijk 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DNS Forwarder
Target version:
Start date:
08/13/2017
Due date:
% Done:

100%

Affected Version:
2.3.4_1
Affected Architecture:

Description

Add a host override in DNS Forwarder (dnsmasq):

  • Host: myhost
  • Domain: mydomain
  • IP address: 1.2.3.4

Forward lookup of myhost.mydomain will correctly return 1.2.3.4.
Reverse (PTR) lookup of 1.2.3.4 will return only myhost instead of myhost.mydomain.

This worked fine in 2.3.4, the bug appeared in 2.3.4_1. I think this is a regression caused by #7690.

Associated revisions

Revision 0e78c2f5
Added by Jim Pingle 2 months ago

Put the FQDN first in /etc/hosts to make dnsmasq happy when reverse resolving hostnames. Make a special exception for localhost. Fixes #7771

Revision de7d6cb8
Added by Jim Pingle 2 months ago

Put the FQDN first in /etc/hosts to make dnsmasq happy when reverse resolving hostnames. Make a special exception for localhost. Fixes #7771

(cherry picked from commit 0e78c2f544ad577234a0a2f87ce2e8caefdfdb77)

Revision f704d091
Added by Jim Pingle 2 months ago

Put the FQDN first in /etc/hosts to make dnsmasq happy when reverse resolving hostnames. Make a special exception for localhost. Fixes #7771

(cherry picked from commit 0e78c2f544ad577234a0a2f87ce2e8caefdfdb77)
(cherry picked from commit de7d6cb87d600c6e093aa3e9f76246fe62824ac7)

History

#1 Updated by Jim Pingle 2 months ago

  • Status changed from New to Confirmed
  • Assignee set to Jim Pingle
  • Target version set to 2.3.4_2

I'll take a look at this closer. I changed the order there since it made the code more consistent and it eliminated a weird special-case exception for localhost. I was focused on unbound on that other ticket, so I didn't catch that PTRs in dnsmasq were behaving differently.

#2 Updated by Jim Pingle 2 months ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#3 Updated by Richard van Dijk 2 months ago

It works with your changes, thanks!

#4 Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Resolved

Looks good on the latest snapshot.

Also available in: Atom PDF