Project

General

Profile

Actions

Bug #7798

closed

DynDNS client does not update when running on a gateway group.

Added by Steve Wheeler about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
-
Start date:
08/22/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3.4_1
Affected Architecture:

Description

When a DynDNS client is set to run on a gateway group rather than an interface directly it fails to run the update script if an interface in that group changes.

When run on the interface directly it successfully runs and updates as expected when the interface goes down and when it comes back up.

When using the failover group it will run and update to the correct IP if triggered manually by editing and the dyndns client and forcing and update.

With the dyndns client on the interface directly:

Aug 22 14:33:27 pfsense kernel: sk1: link state changed to DOWN
Aug 22 14:33:27 pfsense check_reload_status: Linkup starting sk1
Aug 22 14:33:28 pfsense check_reload_status: Reloading filter
Aug 22 14:33:41 pfsense check_reload_status: updating dyndns WAN2
Aug 22 14:33:41 pfsense check_reload_status: Restarting ipsec tunnels
Aug 22 14:33:41 pfsense check_reload_status: updating dyndns BT_DHCP6
Aug 22 14:33:41 pfsense check_reload_status: Restarting OpenVPN tunnels/interfaces
Aug 22 14:33:41 pfsense check_reload_status: Restarting ipsec tunnels
Aug 22 14:33:41 pfsense check_reload_status: Reloading filter
Aug 22 14:33:41 pfsense check_reload_status: Restarting OpenVPN tunnels/interfaces
Aug 22 14:33:41 pfsense check_reload_status: Reloading filter
Aug 22 14:33:42 pfsense php-fpm48513: /rc.dyndns.update: MONITOR: WAN2 is down, omitting from routing group LoadBalance 8.8.4.4|12.34.56.78|WAN2|6.24ms|0.204ms|21%|down
Aug 22 14:33:42 pfsense php-fpm48513: /rc.dyndns.update: phpDynDNS (dyndns.host.name): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
Aug 22 14:33:43 pfsense php-fpm52014: /rc.dyndns.update: phpDynDNS (dyndns.host.name): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
Aug 22 14:33:43 pfsense php-fpm48513: /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use WAN2.
Aug 22 14:33:43 pfsense php-fpm48513: /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use BT_DHCP6.
Aug 22 14:33:53 pfsense ppp: [opt4_link0] LCP: no reply to 1 echo request(s)

...WAN is down....

Aug 22 14:38:05 pfsense check_reload_status: updating dyndns opt4
Aug 22 14:38:05 pfsense check_reload_status: Reloading filter
Aug 22 14:38:06 pfsense php-fpm47667: /rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 12.34.56.78 -> 12.34.56.78 - Restarting packages.
Aug 22 14:38:06 pfsense check_reload_status: Starting packages
Aug 22 14:38:06 pfsense php-fpm55900: /rc.dyndns.update: phpDynDNS (dyndns.host.name): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
Aug 22 14:38:07 pfsense php-fpm47667: /rc.start_packages: Restarting/Starting all packages.

With the dyndns client on the failover gateway group:

ug 22 14:57:37 pfsense check_reload_status: Linkup starting sk1
Aug 22 14:57:37 pfsense kernel: sk1: link state changed to DOWN
Aug 22 14:57:38 pfsense check_reload_status: Reloading filter
Aug 22 14:57:53 pfsense check_reload_status: updating dyndns WAN2
Aug 22 14:57:53 pfsense check_reload_status: Restarting ipsec tunnels
Aug 22 14:57:53 pfsense check_reload_status: updating dyndns BT_DHCP6
Aug 22 14:57:53 pfsense check_reload_status: Restarting OpenVPN tunnels/interfaces
Aug 22 14:57:53 pfsense check_reload_status: Restarting ipsec tunnels
Aug 22 14:57:53 pfsense check_reload_status: Reloading filter
Aug 22 14:57:53 pfsense check_reload_status: Restarting OpenVPN tunnels/interfaces
Aug 22 14:57:53 pfsense check_reload_status: Reloading filter
Aug 22 14:57:54 pfsense php-fpm87950: /rc.dyndns.update: MONITOR: WAN2 is down, omitting from routing group LoadBalance 8.8.4.4|12.34.56.78|WAN2|6.472ms|0.463ms|21%|down
Aug 22 14:57:54 pfsense php-fpm87950: /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use WAN2.
Aug 22 14:57:54 pfsense php-fpm87950: /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use BT_DHCP6.
Aug 22 14:58:03 pfsense ppp: [opt4_link0] LCP: no reply to 1 echo request(s)

...WAN is down...

Aug 22 15:03:16 pfsense check_reload_status: updating dyndns opt4
Aug 22 15:03:16 pfsense check_reload_status: Reloading filter
Aug 22 15:03:16 pfsense php-fpm63637: /rc.start_packages: Restarting/Starting all packages.
Aug 22 15:03:16 pfsense php-fpm63637: lcdproc: Sync: Begin package sync
Aug 22 15:03:16 pfsense php-fpm63637: lcdproc: Sync: End package sync
Aug 22 15:03:16 pfsense check_reload_status: Reloading filter

Actions #1

Updated by Steve Wheeler about 4 years ago

Also see ticket 25792.

Actions #2

Updated by Jim Pingle about 4 years ago

  • Status changed from New to Duplicate

Duplicate of #7719

Actions

Also available in: Atom PDF