Project

General

Profile

Bug #7896

picture_widget.php

Added by Valentin Bajrami almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Very Low
Assignee:
-
Category:
Web Interface
Target version:
Start date:
09/27/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3.4
Affected Architecture:

Description

Hi everyone,

First of all, thanks a bunch for such an effort you put on developing this awesome application. While, I was testing a clean install I stumbled upon the following.

1) Click on + sign to add the Picture windget.
2) The widget appears on the Dashboard
3) Click on the blue link 'Picture' and the picture_widget.php is being downloaded.

Is this intentionally or it escaped your attention?

What works is this: Once a first upload has taken place and I'd click again on the 'Picture' link, the recent uploaded file would be downloaded. So apparently the widget wants to have something uploaded before you can click on the link and get the desired result.

Maybe it's not a bug and my apologies for that, if so please see if this can be fixed.

Associated revisions

Revision dc91c949 (diff)
Added by Stephen Jones almost 2 years ago

Fixed #7896
Handled the case where there is no picture and made it simpler to load
a picture.

Revision 1f8a9b40 (diff)
Added by Stephen Jones almost 2 years ago

Fixed #7896
Handled the case where there is no picture and made it simpler to load
a picture.

(cherry picked from commit dc91c9490a61c374b4358a3a328019f3e0e150ab)

Revision c676c135 (diff)
Added by Stephen Jones almost 2 years ago

Fixed #7896
2.3 is slightly different than 2.4 with different variables so this
fix is different than the 2.4 version.

Revision 00fc2d5e (diff)
Added by Stephen Jones almost 2 years ago

Fixed #7896 Made sure only images could be uploaded and validated on the server to make sure it is an image and not something else.

History

#1 Updated by Steve Beaver almost 2 years ago

  • Assignee changed from Jim Pingle to Anonymous

#2 Updated by Anonymous almost 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Assigned
  • Target version set to 2.4.3

If you save the widget with no picture, it makes a link that says "picture" and that still has the original problem.

The picture tag is in the configuration for the widgets, but it has no other settings.

                <picture-0>
                        <descr><![CDATA[Picture]]></descr>
                </picture-0>

It should probably detect that case and still present the form as if there was no picture.

#4 Updated by Anonymous almost 2 years ago

  • Status changed from Assigned to Feedback

#5 Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved
  • Target version changed from 2.4.3 to 2.4.2

Looks good now, thanks!

Also available in: Atom PDF