Project

General

Profile

Bug #7913

Applying wizard for creating Traffic Shapers with PRIQ and Prioritize VoIP traffic doesn't create qVoIP and Floating Rule

Added by Azamat Khakimyanov about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
10/06/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4
Affected Architecture:

Description

For 2.3.4_p1 traffic shaper wizard with PRIQ and enabling VoIP creates qVoIP and Floating Rule
pfctl -sa ALTQ:
queue qACK on em0 priority 6 priq( red ecn )
queue qDefault on em0 priority 3 priq( red ecn default )
queue qVoIP on em0 priority 7 priq( red ecn )
queue qLink on em1 priority 2 qlimit 500 priq( red ecn default )
queue qACK on em1 priority 6 priq( red ecn )
queue qVoIP on em1 priority 7 priq( red ecn )

BUT for current snap 2.4.0.r.20171005.1721 wizard doesn't create qVoIP and Floating Rule
pfctl -sa ALTQ:
queue qACK on em0 priority 6 priq( red ecn )
queue qDefault on em0 priority 3 priq( red ecn default )
queue qLink on em1 priority 2 qlimit 500 priq( red ecn default )
queue qACK on em1 priority 6 priq( red ecn )
When I enabled other options (Gaming and other network protocol) related queues were created but not qVoIP/FloatingRule.

Associated revisions

Revision 10e93284 (diff)
Added by Jim Pingle about 2 years ago

Unbreak PRIQ queue creation for VoIP, Penalty Box, and P2P options. Fixes #7913

Revision e94ca10f (diff)
Added by Jim Pingle about 2 years ago

Unbreak PRIQ queue creation for VoIP, Penalty Box, and P2P options. Fixes #7913

(cherry picked from commit 10e93284be3cd62fe871710205e61de0e36dcc2f)

History

#1 Updated by Jim Pingle about 2 years ago

  • Target version set to 2.4.0

#2 Updated by Jim Pingle about 2 years ago

This was caused by 7798eb1e6ac48963a2785b449306cb49c942381f - I just pushed a fix that changes the tests a bit so it still avoids the math issue on PRIQ but also creates the queues properly.

#3 Updated by Jim Pingle about 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Jim Pingle about 2 years ago

  • Status changed from Feedback to Resolved

Fixed in current snapshots

Also available in: Atom PDF