Project

General

Profile

Todo #7938

Change pfSense-upgrade to use pkg-static instead of pkg

Added by Jim Pingle over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
10/13/2017
Due date:
% Done:

100%

Estimated time:

Description

pfSense-upgrade should use pkg-static internally, rather than pkg, to avoid issues with major version upgrades, potential missing or mismatched shared libraries, and so on.

It is a larger binary and therefore may consume more resources when invoked, but the benefits appear to outweigh that concern.

History

#1 Updated by Renato Botelho over 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

pfSense-upgrade version 0.27_2 on 2.3.x and 0.34 on 2.4.x are changed

#2 Updated by Jim Pingle over 2 years ago

  • Status changed from Feedback to Resolved

Looks to me like all of the references in the pfSense-upgrade code now call pkg-static so this is done.

Also available in: Atom PDF