Bug #8034


PHP crashes when trying to modify or add NAT rules in pfSense v.2.4.1

Added by Alessandro Bariatti over 6 years ago. Updated over 5 years ago.

Web Interface
Target version:
Start date:
Due date:
% Done:


Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:


Hello, I'm running pfSense v2.4.1, upgraded from v2.4.0 yesterday.

Every time I try to add or modify a NAT rule in any tab (Port Forwaring, NAT 1:1, Outbound, NPt) I get a blank page.

Going back to pfSense web interface home, I get this message "pfSense has detected a crash report or programming bug.".

This is preventing me to add some needed rules in a production machine.

VM is running with 4GB of RAM allocated, most of them free, Load average 0.49, 0.49, 0.28.

Here the details, already submitted to developers.

Crash report begins.  Anonymous machine information:
FreeBSD 11.1-RELEASE-p2 #6 r313908+7eae9364d25(RELENG_2_4): Sun Oct 22 17:32:35 CDT 2017 :/builder/ce-241/tmp/obj/builder/ce-241/tmp/FreeBSD-src/sys/pfSense
Crash report details:
PHP Errors:
[31-Oct-2017 11:09:56 Europe/Rome] PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 32 bytes) in /etc/inc/ on line 324
[31-Oct-2017 11:09:56 Europe/Rome] PHP Stack trace:
[31-Oct-2017 11:09:56 Europe/Rome] PHP 1. {main}() /usr/local/www/firewall_nat_edit.php:0
[31-Oct-2017 11:09:56 Europe/Rome] PHP 2. dsttype_selected() /usr/local/www/firewall_nat_edit.php:813
[31-Oct-2017 11:09:56 Europe/Rome] PHP 3. build_dsttype_list() /usr/local/www/firewall_nat_edit.php:663
[31-Oct-2017 11:09:56 Europe/Rome] PHP 4. long2ip32() /usr/local/www/firewall_nat_edit.php:641
Actions #1

Updated by Jim Pingle over 6 years ago

  • Status changed from New to Rejected
  • Priority changed from Urgent to Normal

Please post on the forum, reddit, or the mailing list to discuss this in detail before opening a bug report. There may be an issue there but there is not nearly enough information provided to begin tracking it down. For example, the place where the report claims it crashed is in creating a list of existing VIPs, so perhaps you have an invalid entry in your VIPs, but we need to discuss that somewhere to get the details, and this is not a discussion platform.

Actions #2

Updated by Sorin Sbarnea over 5 years ago

I got exactly the same error inside the crash reporter, including the max memory size even if my pfsense machine has 8GB RAM. This makes me believe that it should a system tunable config that we could use to increase max memory.


Also available in: Atom PDF