Project

General

Profile

Bug #8050

Enabling bridge while interfaces have link freezes console

Added by Clinton Cory about 3 years ago. Updated about 3 years ago.

Status:
New
Priority:
High
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
11/03/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.2
Affected Architecture:

Description

Installed 2.4.2-DEV CE (snapshot from about an hour ago) on both a VM and XG-2758.

If you try to create a bridge with interfaces that have physical link the entire system freezes and hangs.

You CAN create a bridge if the interfaces are in a state of "no carrier" (no physical link).

I installed pfSense on a SG-2220 and tried to bridge two VLAN interfaces on a physical interface with no link. It worked just fine but eventually encountered the same problem. It's possible that even a bridge with no links to it's member interfaces may eventually freeze as well - I haven't been able to verify that yet.

VLAN bridge test was with 2.4.2-DEV Factory.

This may be related to changes related to this bug report:
https://redmine.pfsense.org/issues/7940

History

#1 Updated by Clinton Cory about 3 years ago

Also may be related to changes here:
https://redmine.pfsense.org/issues/7936

#2 Updated by Clinton Cory about 3 years ago

Same issue with 2.4.1

#3 Updated by Clinton Cory about 3 years ago

PF was disabled during these tests and no IP assigned to the bridge interface. I had a similar problem with 2.3.5...

Trying 2.3.4_p1 with PF enabled.

#4 Updated by Clinton Cory about 3 years ago

This may be an issue on my end, with VMware...it's possible I saw what appeared to be the same issue on the XG-2758 because it dropped network connectivity while I was remotely consoled in. The SG-2220 that I had setup VLAN bridge on before trying this on the XG-2758 may have appeared to break because my network connectivity was hung once the XG-2758 bridge was made.

Also available in: Atom PDF