Project

General

Profile

Bug #8110

undefined functions validate_gateway($_post, $id) and save_gateway($_POST, $realid) in system_gateways_edit.php

Added by Peter Schofield over 1 year ago. Updated over 1 year ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Gateways
Target version:
-
Start date:
11/20/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.1
Affected Architecture:

Description

While setting up he.net 6 to 4 tunnel as per the howto documented in the wiki, I ran into this while making the edits to the gateway.

Clicking the save button gives a PHP error undefined function validate_gateway() on line 97, Commenting out that line then gives undefined function save_gateway on line 100

I'm assigning this high priority because as it stands it's not possible to edit gateway configs via the webui. This bug really shouldn't have made it to release. As far as I can tell it's still present in the latest master.

History

#1 Updated by Jim Pingle over 1 year ago

  • Status changed from New to Not a Bug
  • Priority changed from High to Normal

Those functions are defined in source:src/etc/inc/gwlb.inc which is included through functions.inc which is included in guiconfig.inc which is included in system_gateways_edit.php.

Something is broken in your installation, not a bug.

Please post on the forum, reddit, or mailing list for assistance with fixing your system.

#2 Updated by Random User over 1 year ago

Jim Pingle wrote:

hose functions are defined in source:src/etc/inc/gwlb.inc which is included through functions.inc which is included in guiconfig.inc which is included in system_gateways_edit.php.

Which of course is an excellent way of doing things (cf. #7385)

#3 Updated by Peter Schofield over 1 year ago

those functions are NOT present in gwlb.inc in my install, and the file is not damaged. Clearly this is a partial update and either the update I installed was released halfway through a refactor or the updater does no integrity checking, and subsequently reports success when it's only done half the update. Either way shouldn't happen.

#4 Updated by Jim Pingle over 1 year ago

The update process does check the integrity, but it's possible some other problem (disk issue, for example) can cause it to appear to work or fail later. Either way, this is not a bug as stated. Discuss it elsewhere and if a specific, repeatable problem case can be identified then we can open a bug to address that.

Also available in: Atom PDF