Project

General

Profile

Bug #8119

Site to Site IPsec On a VM Not Routing

Added by Kristopher Kolpin about 2 months ago. Updated 5 days ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
IPsec
Target version:
-
Start date:
11/22/2017
Due date:
% Done:

0%

Affected Version:
2.4.2
Affected Architecture:
amd64

Description

Following the guide at:

https://doc.pfsense.org/index.php/Routing_internet_traffic_through_a_site-to-site_OpenVPN-connection_in_PfSense_2.1

I was able to set up a site to site IPsec VPN on two bare metal systems (separated on the public internet) where one pfSense system acts as the gateway to the internet for the other system.

Everything works great.

However, when I set up a separate bare metal system to connect to (and route all internet access through as well) a pfSense system on a VM I get no routing whatsoever. I cannot even ping the other end. I've set everything up identically except for the fact that its a VM. The IPsec tunnels establish OK though.

To see if something was wonky with my VPS provider I set up another set of systems to allow the same setup but over OpenVPN and everything works as expected.

Everything system was on 2.4.2-Release-amd64.

History

#1 Updated by Jim Pingle 5 days ago

  • Status changed from New to Not a Bug
  • Target version deleted (2.4.3)

Seems more like a configuration issue. pfSense doesn't care if it's running on a VM or bare metal, IPsec wouldn't have any idea. Please post on the forum or mailing list for help tracking down the actual underlying issue in your environment.

Also available in: Atom PDF