Project

General

Profile

Actions

Bug #8409

closed

pfsense alias complains about well known name for non well known port

Added by lists b over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Very Low
Assignee:
Category:
Rules / NAT
Target version:
Start date:
03/31/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:
All

Description

when attempting to add a new port alias [firewall -> aliases -> ports -> add], for example, for mdns [udp port 5353], pfsense complains "The alias name must not be a well-known TCP or UDP port name [...]" [see attached screen shot].

well known ports are 0-1023. if this mechanism is actually checking more than just well-known ports, and is working as intended, to include all official/registered ports in the constraint, it would be best if the feedback conveyed that.


Files

Actions #1

Updated by Jim Pingle over 3 years ago

  • Category set to Rules / NAT
  • Status changed from New to Assigned
  • Assignee set to Jim Pingle
  • Priority changed from Normal to Very Low
  • Target version set to 2.4.4
  • Affected Version set to All
  • Affected Architecture All added
  • Affected Architecture deleted ()
Actions #2

Updated by Jim Pingle over 3 years ago

IIRC it is checking well-known and registered ports, basically anything in /etc/services which are considered keywords in pf which makes them unsuitable for use as alias names.

Actions #3

Updated by Jim Pingle over 3 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Anonymous over 3 years ago

Tested on latest 2.4.4 CE snapshot gitsync'd to master, works as expected.

Actions #5

Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved
Actions #6

Updated by Jim Pingle about 3 years ago

  • Target version changed from 2.4.4 to 2.4.3-p1
Actions

Also available in: Atom PDF