Project

General

Profile

Todo #8433

Upgrade NRPE-SSL Package to NRPE3

Added by Ken Sim over 2 years ago. Updated almost 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
NRPE
Target version:
-
Start date:
04/04/2018
Due date:
% Done:

100%

Estimated time:

Description

net-mgmt/nrpe-ssl (https://www.freshports.org/net-mgmt/nrpe-ssl/) has been depreciated and removed since January. Can we switch net-mgmt/nrpe-ssl for net-mgmt/nrpe3 as its supported. The configuration is the same, I have been running net-mgmt/nrpe3 in place of net-mgmt/nrpe-ssl without any issues. I would do it myself but I am not sure how to.

History

#1 Updated by Jim Pingle over 2 years ago

  • Tracker changed from Bug to Todo
  • Status changed from New to Feedback

It is already switched to nrpe3 on 2.4.4 snapshots because the nrpe2 and nrpe-ssl ports were removed from the FreeBSD ports tree.

If we can get some more confirmation that it is working fine there, perhaps the same adjustment can be made for 2.4.3.

#2 Updated by Ken Sim over 2 years ago

Oh sorry I wasn't aware it was already done in the snapshots, haven't used them in a long time.

#3 Updated by Jim Pingle about 2 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Jim Pingle

Looks like this does need some changes in the package to function. I've got it working here, will push shortly.

nrpe3 is in 2.4.4 snapshots and now also in 2.3.5-p2, if the new code works we can consider cherry-picking the changes to 2.4.3-p1.

#4 Updated by Jim Pingle about 2 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

This should be up and ready for testing now.

#5 Updated by Yehuda Katz about 2 years ago

Good timing. Ubuntu 18.04 ships with a new version of OpenSSL that stops check_nrpe from contacting old versions because of bad SSL cipher choices. The easiest fix seems to be upgrading NRPE.

#6 Updated by Ken Sim about 2 years ago

Jim,

Is it possible to get it back ported to 2.4.3-p1 or is there still some issues that need to be worked out?

Thanks

#7 Updated by Jim Pingle about 2 years ago

I haven't had any feedback on how well (if at all) that it works. If it can get some testing, at least on 2.4.4, then it can probably be backported.

#8 Updated by Ken Sim about 2 years ago

How can I go about testing it on 2.4.3-p1 to help out? I currently just have the nrpe3 package installed from the FreeBSD PKG repo.

#9 Updated by Jim Pingle about 2 years ago

The only valid test would be on 2.4.4 or 2.3.5-p2 (where it wasn't intended to be yet, but ended up after the last releast)

#10 Updated by Jim Pingle almost 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF