Project

General

Profile

Bug #8498

cloudflare Dynamic DNS is not working

Added by Mohammad Makkawi almost 2 years ago. Updated almost 2 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
-
Start date:
05/04/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.3
Affected Architecture:
amd64

Description

cloudflare Dynamic DNS is not working

01.JPG (161 KB) 01.JPG I used my Cloudflare email for the user and the Global API Key for the password Mohammad Makkawi, 05/13/2018 02:46 PM
02.JPG (83.7 KB) 02.JPG Cloudflare configuration Mohammad Makkawi, 05/13/2018 02:51 PM
Capture+_2018-05-23-11-03-10.png (1.78 MB) Capture+_2018-05-23-11-03-10.png Mohammad Makkawi, 05/23/2018 03:03 AM

History

#1 Updated by Michael Geiger almost 2 years ago

DynamicDNS with Cloudflare works for me with 2.4.3-RELEASE (amd64)
Updates for IPv6 and IPv4 are sucessfull

Could you please provide more details, log files etc.

#2 Updated by Mohammad Makkawi almost 2 years ago

the error from the logs:
is
May 13 22:31:28 php-fpm 312 /services_dyndns_edit.php: phpDynDNS (@): (Error) Zone or Host ID was not found, check the hostname.

I added 2 pictures for the configuration on pfsense and Cloudflare.

please tell me if I did anything wrong.

note:
I am using IP4 only.
I have an other DDNS with noip and it is working.
If use my IP manually in Cloudflare it works.
I have tried many configuration on the hostname none is working.

#3 Updated by Mohammad Makkawi almost 2 years ago

Now it is working with 2.4.3 p1

Also I added dynamic in cloudflare and in the host name

See attached picture

#4 Updated by Michael Geiger almost 2 years ago

This was an issue in your configuration and no bug oft pfsense.

You had no entry makkawi.win in cloudflare. So pfsense was not able to update an record.

Changing the hostname from @ to dynamic fixed the issue because you have an Entry dynamic.makkawi.win in cloudflare.

#5 Updated by Jim Pingle almost 2 years ago

  • Status changed from New to Not a Bug
  • Target version deleted (2.4.4)

Also available in: Atom PDF