Project

General

Profile

Bug #8510

Loopback virtual IP does not survive a reboot.

Added by Ryan Haraschak over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Virtual IP Addresses
Target version:
-
Start date:
05/07/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.3
Affected Architecture:
amd64

Description

Impact:
  • Monitoring and remote administration via loopback virtual IP is broken after a reboot. With services like NRPE & NET-SNMP bound to this IP, they fail to start until the recovery steps are performed.
Expected:
  • IP Alias survives reboot, assigned prior to start of packages.
Steps to reproduce:
  • Navigate to firewall_virtual_ip.php
  • Create new IP Alias type on Localhost, Single address, /32
  • Click Save, Apply Changes
Steps to recover:
  • Navigate to firewall_virtual_ip.php
  • Edit existing Loopback virtual IP
  • Click Save, Apply Changes
Additional info:
  • Also affects SG-1000
  • Using dynamic routing and multiple paths to the firewalls, binding NRPE and SNMP to physical or VPN interfaces would not guarantee a connection. Rather, using a loopback interface, accessible by multiple paths (BGP, OSPF, etc...), would remain up when physical or VPN interfaces are down.

History

#1 Updated by Jim Pingle over 2 years ago

  • Status changed from New to Duplicate

Duplicate of #8393

Also available in: Atom PDF